aboutsummaryrefslogtreecommitdiffstats
path: root/editors/jext
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-16 02:21:14 +0800
committermarcus <marcus@FreeBSD.org>2003-11-16 02:21:14 +0800
commit8597e47e4b6614e659f114abd2fcd86aa02b5e3a (patch)
treeabd1b608afdcac786ba3b7af013e69d3b9b8bda6 /editors/jext
parent5383bc5299fdd96d621ca61d863bb4db4615851a (diff)
downloadfreebsd-ports-gnome-8597e47e4b6614e659f114abd2fcd86aa02b5e3a.tar.gz
freebsd-ports-gnome-8597e47e4b6614e659f114abd2fcd86aa02b5e3a.tar.zst
freebsd-ports-gnome-8597e47e4b6614e659f114abd2fcd86aa02b5e3a.zip
unPERLify by using REINPLACE_CMD where appropriate.
PR: 48248 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'editors/jext')
-rw-r--r--editors/jext/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/editors/jext/Makefile b/editors/jext/Makefile
index 5b3e701d3e10..52f07a8029f7 100644
--- a/editors/jext/Makefile
+++ b/editors/jext/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/javavmwrapper \
WRKSRC= ${WRKDIR}
USE_XLIB= yes
+USE_REINPLACE= yes
NO_BUILD= yes
JAVAVM?= ${LOCALBASE}/bin/javavm
@@ -27,8 +28,8 @@ JAVAVM?= ${LOCALBASE}/bin/javavm
INSTSBDR= ${PREFIX}/share/java/jext
do-configure:
- @${PERL} -pi -e 's|%%JAVAVM%%|${JAVAVM}|g ; \
- s|%%JEXT_HOME%%|${INSTSBDR}|g' ${WRKSRC}/bin/jext
+ @${REINPLACE_CMD} -e 's|%%JAVAVM%%|${JAVAVM}|g ; \
+ s|%%JEXT_HOME%%|${INSTSBDR}|g' ${WRKSRC}/bin/jext
do-install:
@${MKDIR} ${INSTSBDR}