aboutsummaryrefslogtreecommitdiffstats
path: root/editors/joe
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-10-08 18:17:59 +0800
committertobik <tobik@FreeBSD.org>2017-10-08 18:17:59 +0800
commit61a1c23908a047e0a4ff15d39345ce56f5da136e (patch)
treed20c4acc5818edd8443de2c7470eb7d4daac672a /editors/joe
parent2e9664bf00749a0f7e39ec923e3ed02f28bac11c (diff)
downloadfreebsd-ports-gnome-61a1c23908a047e0a4ff15d39345ce56f5da136e.tar.gz
freebsd-ports-gnome-61a1c23908a047e0a4ff15d39345ce56f5da136e.tar.zst
freebsd-ports-gnome-61a1c23908a047e0a4ff15d39345ce56f5da136e.zip
editors/joe: Update to 4.5
While here - Add missing LICENSE_FILE - Switch to options helpers - USES=localbase - Delete configure patch and set aspell directly via CONFIGURE_ENV - Drop obsolete patch-tty.c. setpgrp() always takes two arguments on supported FreeBSD releases and SETPGRP_VOID should always be undefined. Changes: https://sourceforge.net/p/joe-editor/mercurial/ci/default/tree/NEWS.md PR: 222565 Approved by: juergen.gotteswinter@googlemail.com (maintainer timeout, 2 weeks)
Diffstat (limited to 'editors/joe')
-rw-r--r--editors/joe/Makefile25
-rw-r--r--editors/joe/distinfo5
-rw-r--r--editors/joe/files/patch-configure11
-rw-r--r--editors/joe/files/patch-tty.c13
-rw-r--r--editors/joe/pkg-plist29
5 files changed, 33 insertions, 50 deletions
diff --git a/editors/joe/Makefile b/editors/joe/Makefile
index 6d9b39068ea4..5e7896147448 100644
--- a/editors/joe/Makefile
+++ b/editors/joe/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= joe
-PORTVERSION= 4.2
-PORTREVISION= 1
+PORTVERSION= 4.5
PORTEPOCH= 1
CATEGORIES?= editors
MASTER_SITES= SF/joe-editor/JOE%20sources/joe-${PORTVERSION}
@@ -12,31 +11,27 @@ MAINTAINER= juergen.gotteswinter@googlemail.com
COMMENT= Joe's Own Editor
LICENSE= GPLv2
-
-
-OPTIONS_DEFINE= ASPELL DOCS
+LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= joe-2.*
-USES= gmake iconv ncurses
+USES= gmake iconv localbase ncurses
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+CONFIGURE_ENV= SPELL=aspell
+LIBS+= ${ICONV_LIB}
ALL_TARGET= ${PORTNAME}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= ASPELL DOCS
-.if ${PORT_OPTIONS:MASPELL}
-RUN_DEPENDS= aspell:textproc/aspell
-.endif
+ASPELL_RUN_DEPENDS= aspell:textproc/aspell
post-patch:
${REINPLACE_CMD} -e 's|docs/README.old docs/man.md ||' ${WRKSRC}/Makefile.in
post-install:
- for rc in jmacsrc joerc jpicorc jstarrc rjoerc; do \
- ${MV} ${STAGEDIR}${ETCDIR}/$${rc} ${STAGEDIR}${ETCDIR}/$${rc}.sample ; \
- done
+.for rc in ftyperc jmacsrc joerc jpicorc jstarrc rjoerc
+ ${MV} ${STAGEDIR}${ETCDIR}/${rc} ${STAGEDIR}${ETCDIR}/${rc}.sample
+.endfor
.include <bsd.port.mk>
diff --git a/editors/joe/distinfo b/editors/joe/distinfo
index 6048292afa7b..03698a71326e 100644
--- a/editors/joe/distinfo
+++ b/editors/joe/distinfo
@@ -1,2 +1,3 @@
-SHA256 (joe-4.2.tar.gz) = bc5da64bc5683ab7b2962a33214b3537ea17ff6528a3c60ba170359e31e86974
-SIZE (joe-4.2.tar.gz) = 1341048
+TIMESTAMP = 1506265626
+SHA256 (joe-4.5.tar.gz) = 51104aa34d8650be3fa49f2204672a517688c9e6ec47e68f1ea85de88e36cadf
+SIZE (joe-4.5.tar.gz) = 1275486
diff --git a/editors/joe/files/patch-configure b/editors/joe/files/patch-configure
deleted file mode 100644
index b56227134214..000000000000
--- a/editors/joe/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2016-03-06 19:35:47.000000000 +0000
-+++ configure 2016-06-05 13:46:54.833041496 +0000
-@@ -8145,7 +8145,7 @@
- done
- IFS=$as_save_IFS
-
-- test -z "$ac_cv_prog_SPELL" && ac_cv_prog_SPELL="ispell"
-+ test -z "$ac_cv_prog_SPELL" && ac_cv_prog_SPELL="aspell"
- fi
- fi
- SPELL=$ac_cv_prog_SPELL
diff --git a/editors/joe/files/patch-tty.c b/editors/joe/files/patch-tty.c
deleted file mode 100644
index a5c1ccffd6e4..000000000000
--- a/editors/joe/files/patch-tty.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- joe/tty.c Fri Mar 18 10:40:11 2005
-+++ joe/tty.c Fri May 6 16:58:38 2005
-@@ -1074,8 +1074,10 @@
- setsid(); /* I think you do setprgp(0,0) on systems with no setsid() */
- #ifndef SETPGRP_VOID
- setpgrp(0, 0);
-+/*
- #else
- setpgrp();
-+*/
- #endif
-
- #endif
diff --git a/editors/joe/pkg-plist b/editors/joe/pkg-plist
index 8544a6a62e8a..c416ac79ef33 100644
--- a/editors/joe/pkg-plist
+++ b/editors/joe/pkg-plist
@@ -3,26 +3,37 @@ bin/joe
bin/jpico
bin/jstar
bin/rjoe
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/hacking.md
-%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
-%%PORTDOCS%%%%DOCSDIR%%/README.md
-%%ETCDIR%%/ftyperc
+@sample %%ETCDIR%%/ftyperc.sample
%%ETCDIR%%/jicerc.ru
@sample %%ETCDIR%%/jmacsrc.sample
@sample %%ETCDIR%%/joerc.sample
+%%ETCDIR%%/joerc.zh_TW
@sample %%ETCDIR%%/jpicorc.sample
@sample %%ETCDIR%%/jstarrc.sample
@sample %%ETCDIR%%/rjoerc.sample
%%ETCDIR%%/shell.csh
%%ETCDIR%%/shell.sh
-%%ETCDIR%%/joerc.zh_TW
+man/man1/joe.1.gz
+man/ru/man1/joe.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/hacking.md
%%DATADIR%%/charmaps/klingon
+%%DATADIR%%/colors/default.jcf
+%%DATADIR%%/colors/gruvbox.jcf
+%%DATADIR%%/colors/ir_black.jcf
+%%DATADIR%%/colors/molokai.jcf
+%%DATADIR%%/colors/solarized.jcf
+%%DATADIR%%/colors/wombat.jcf
+%%DATADIR%%/colors/xoria.jcf
+%%DATADIR%%/colors/zenburn-hc.jcf
+%%DATADIR%%/colors/zenburn.jcf
%%DATADIR%%/lang/de.po
%%DATADIR%%/lang/fr.po
%%DATADIR%%/lang/ru.po
%%DATADIR%%/lang/uk.po
-%%DATADIR%%/lang/zh.po
+%%DATADIR%%/lang/zh_TW.po
%%DATADIR%%/syntax/4gl.jsf
%%DATADIR%%/syntax/ada.jsf
%%DATADIR%%/syntax/ant.jsf
@@ -36,6 +47,7 @@ bin/rjoe
%%DATADIR%%/syntax/coffee.jsf
%%DATADIR%%/syntax/comment_todo.jsf
%%DATADIR%%/syntax/conf.jsf
+%%DATADIR%%/syntax/context.jsf
%%DATADIR%%/syntax/csh.jsf
%%DATADIR%%/syntax/csharp.jsf
%%DATADIR%%/syntax/css.jsf
@@ -58,6 +70,7 @@ bin/rjoe
%%DATADIR%%/syntax/ini.jsf
%%DATADIR%%/syntax/iptables.jsf
%%DATADIR%%/syntax/java.jsf
+%%DATADIR%%/syntax/jcf.jsf
%%DATADIR%%/syntax/joerc.jsf
%%DATADIR%%/syntax/js.jsf
%%DATADIR%%/syntax/jsf.jsf
@@ -102,5 +115,3 @@ bin/rjoe
%%DATADIR%%/syntax/whitespace.jsf
%%DATADIR%%/syntax/xml.jsf
%%DATADIR%%/syntax/yaml.jsf
-man/man1/joe.1.gz
-man/ru/man1/joe.1.gz