aboutsummaryrefslogtreecommitdiffstats
path: root/editors/kile-kde4/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-09-13 01:08:04 +0800
committermakc <makc@FreeBSD.org>2009-09-13 01:08:04 +0800
commit2d414272949fcddfb11f471d44dc3e6297d7f06c (patch)
tree8c6aa49d5a852bf681266c241464812d05f8c9ea /editors/kile-kde4/Makefile
parent0229555df550aba8d5bebd1b6a6854c9fa892a04 (diff)
downloadfreebsd-ports-gnome-2d414272949fcddfb11f471d44dc3e6297d7f06c.tar.gz
freebsd-ports-gnome-2d414272949fcddfb11f471d44dc3e6297d7f06c.tar.zst
freebsd-ports-gnome-2d414272949fcddfb11f471d44dc3e6297d7f06c.zip
Update to 2.1b1 for KDE4
Diffstat (limited to 'editors/kile-kde4/Makefile')
-rw-r--r--editors/kile-kde4/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index 839b7c78708c..90e0fd23a2af 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -6,34 +6,31 @@
#
PORTNAME= kile
-PORTVERSION= 2.0.3
-PORTREVISION= 1
+DISTVERSION= 2.1b2
CATEGORIES= editors kde
-MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/unstable/${PORTNAME}-${DISTVERSION}
-MAINTAINER= markus@FreeBSD.org
+MAINTAINER= makc@FreeBSD.org
COMMENT= A LaTeX source editor for KDE
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
identify:${PORTSDIR}/graphics/ImageMagick
-CONFLICTS= kile-i18n-[0-9]*
-
-USE_KDELIBS_VER=3
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:22
-USE_GMAKE= yes
+USE_CMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
+USE_KDE4= kdeprefix kdelibs automoc4
+MAKE_JOBS_SAFE= yes
-OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
+LATEST_LINK= ${PORTNAME}-kde4
-post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's| syntax||g' ${WRKSRC}/src/kile/Makefile.in
+OPTIONS= OKULAR "Use Okular for viewing" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_KPDF)
-RUN_DEPENDS+= kpdf:${PORTSDIR}/graphics/kdegraphics3
+.if !defined(WITHOUT_OKULAR)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/okular:${PORTSDIR}/graphics/kdegraphics4
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>