aboutsummaryrefslogtreecommitdiffstats
path: root/editors/leafpad
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-10-19 06:11:02 +0800
committermezz <mezz@FreeBSD.org>2004-10-19 06:11:02 +0800
commit9f3d07324bfe1fd58e12fa65a13fc1957455ef86 (patch)
treecd192cee9e3a05983d51c458885e3ce110f08382 /editors/leafpad
parent3dbdb6483a39c354ae2ff7634c56817cb58838b0 (diff)
downloadfreebsd-ports-gnome-9f3d07324bfe1fd58e12fa65a13fc1957455ef86.tar.gz
freebsd-ports-gnome-9f3d07324bfe1fd58e12fa65a13fc1957455ef86.tar.zst
freebsd-ports-gnome-9f3d07324bfe1fd58e12fa65a13fc1957455ef86.zip
Leafpad is a GTK+ based simple text editor. The user interface is similar to
"notepad.exe", and it aims to be lighter than GEdit and KWrite, and to be as useful as them. WWW: http://tarot.freeshell.org/leafpad/ PR: ports/72828 Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'editors/leafpad')
-rw-r--r--editors/leafpad/Makefile46
-rw-r--r--editors/leafpad/distinfo2
-rw-r--r--editors/leafpad/pkg-descr5
-rw-r--r--editors/leafpad/pkg-plist11
4 files changed, 64 insertions, 0 deletions
diff --git a/editors/leafpad/Makefile b/editors/leafpad/Makefile
new file mode 100644
index 000000000000..665d25ea4818
--- /dev/null
+++ b/editors/leafpad/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: leafpad
+# Date created: 2004-10-18
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= leafpad
+PORTVERSION= 0.7.3.1
+CATEGORIES= editors
+MASTER_SITES= http://tarot.freeshell.org/leafpad/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Light-weight GTK+ Editor similar to notepad.exe
+
+USE_GNOME= gnomeprefix gtk20
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+DOCS= AUTHORS COPYING ChangeLog INSTALL README
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS= --enable-nls \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+PLIST_SUB+= NLS:=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS:="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/icons|/pixmaps|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/share/icons/|/share/gnome/pixmaps/|g' \
+ ${WRKSRC}/src/callback.c ${WRKSRC}/src/window.c
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/editors/leafpad/distinfo b/editors/leafpad/distinfo
new file mode 100644
index 000000000000..bc548aff6489
--- /dev/null
+++ b/editors/leafpad/distinfo
@@ -0,0 +1,2 @@
+MD5 (leafpad-0.7.3.1.tar.gz) = 8eaf0105cbf86a2c00c833205c10cbee
+SIZE (leafpad-0.7.3.1.tar.gz) = 162439
diff --git a/editors/leafpad/pkg-descr b/editors/leafpad/pkg-descr
new file mode 100644
index 000000000000..5f0732bc1a92
--- /dev/null
+++ b/editors/leafpad/pkg-descr
@@ -0,0 +1,5 @@
+Leafpad is a GTK+ based simple text editor. The user interface is similar to
+"notepad.exe", and it aims to be lighter than GEdit and KWrite, and to be as
+useful as them.
+
+WWW: http://tarot.freeshell.org/leafpad/
diff --git a/editors/leafpad/pkg-plist b/editors/leafpad/pkg-plist
new file mode 100644
index 000000000000..227215e14835
--- /dev/null
+++ b/editors/leafpad/pkg-plist
@@ -0,0 +1,11 @@
+bin/leafpad
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/gnome/pixmaps/leafpad.png
+%%NLS:%%share/locale/ja/LC_MESSAGES/leafpad.mo
+%%NLS:%%share/locale/zh_CN/LC_MESSAGES/leafpad.mo
+%%NLS:%%share/locale/zh_TW/LC_MESSAGES/leafpad.mo
+%%PORTDOCS%%@dirrm %%DOCSDIR%%