aboutsummaryrefslogtreecommitdiffstats
path: root/editors/lfhex
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-03 07:02:32 +0800
committerpav <pav@FreeBSD.org>2004-02-03 07:02:32 +0800
commitd2c62f71e6313b7828b1f1a395db8e08e99bc78f (patch)
treeb973e4555135551d200feaaf454ee501ee8ad6ea /editors/lfhex
parenta63bfb73ee11188e45e98492966c5093649a30fa (diff)
downloadfreebsd-ports-gnome-d2c62f71e6313b7828b1f1a395db8e08e99bc78f.tar.gz
freebsd-ports-gnome-d2c62f71e6313b7828b1f1a395db8e08e99bc78f.tar.zst
freebsd-ports-gnome-d2c62f71e6313b7828b1f1a395db8e08e99bc78f.zip
- Update to 0.3.6
PR: ports/62261 Submitted by: Ports Fury
Diffstat (limited to 'editors/lfhex')
-rw-r--r--editors/lfhex/Makefile8
-rw-r--r--editors/lfhex/distinfo4
-rw-r--r--editors/lfhex/files/patch-src::hexEditor.cpp20
-rw-r--r--editors/lfhex/pkg-plist1
4 files changed, 28 insertions, 5 deletions
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index ff027bf65e57..c26ba439df4a 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= lfhex
-PORTVERSION= 0.3.4
+PORTVERSION= 0.3.6
CATEGORIES= editors
MASTER_SITES= http://home.earthlink.net/~eyekode/data/
@@ -18,10 +18,14 @@ USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qt-moc=${MOC}
-MAKE_ARGS= EXEC_PREFIX="${PREFIX}/bin" \
+MAKE_ARGS= CXXFLAGS="${CXXFLAGS}" \
+ EXEC_PREFIX="${PREFIX}/bin" \
IFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
LFLAGS="${QTCFGLIBS} -lqt-mt ${PTHREAD_LIBS}"
+PLIST_FILES= bin/lfhex
+
.include <bsd.port.mk>
diff --git a/editors/lfhex/distinfo b/editors/lfhex/distinfo
index 6d3dcdaadf75..5e7b52a5a9f7 100644
--- a/editors/lfhex/distinfo
+++ b/editors/lfhex/distinfo
@@ -1,2 +1,2 @@
-MD5 (lfhex-0.3.4.tar.gz) = 59aaa0ed92155106509a2cc9cb36bf1d
-SIZE (lfhex-0.3.4.tar.gz) = 52393
+MD5 (lfhex-0.3.6.tar.gz) = 0d6e363e5637f998dd2fafd6dbd41b6e
+SIZE (lfhex-0.3.6.tar.gz) = 68400
diff --git a/editors/lfhex/files/patch-src::hexEditor.cpp b/editors/lfhex/files/patch-src::hexEditor.cpp
new file mode 100644
index 000000000000..8196ae402213
--- /dev/null
+++ b/editors/lfhex/files/patch-src::hexEditor.cpp
@@ -0,0 +1,20 @@
+--- src/hexEditor.cpp.orig Sun Feb 1 12:49:26 2004
++++ src/hexEditor.cpp Sun Feb 1 20:48:29 2004
+@@ -9,11 +9,12 @@
+ *
+ *----------------------------------------------------------------------*/
+
+-#include <assert.h>
+-#include <stdio.h>
+-#include <errno.h>
+-#include <string.h>
+-#include <ctype.h>
++#include <cassert>
++#include <cstdio>
++#include <cerrno>
++#include <cstring>
++#include <cctype>
++#include <cmath>
+ #include <algorithm>
+ #include <iostream>
+
diff --git a/editors/lfhex/pkg-plist b/editors/lfhex/pkg-plist
deleted file mode 100644
index f468d57ca55d..000000000000
--- a/editors/lfhex/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/lfhex