aboutsummaryrefslogtreecommitdiffstats
path: root/editors/libreoffice
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-05-03 14:37:10 +0800
committerpi <pi@FreeBSD.org>2015-05-03 14:37:10 +0800
commit4f54ff551942f3a691834c87c2d8e5803d5178cf (patch)
tree19ef04e2153f40724a9cc1b54ffc4c67c67bd193 /editors/libreoffice
parent944084c3ecb6db63acc4d2b72377105976a042e2 (diff)
downloadfreebsd-ports-gnome-4f54ff551942f3a691834c87c2d8e5803d5178cf.tar.gz
freebsd-ports-gnome-4f54ff551942f3a691834c87c2d8e5803d5178cf.tar.zst
freebsd-ports-gnome-4f54ff551942f3a691834c87c2d8e5803d5178cf.zip
editors/libreoffice: fix build, if JAVA is selected
... which needs junit, which was updated because it no longer built, which caused a new dependency on hamcrest. PR: 199819 Submitted by: danilo Approved by: just fix it approval
Diffstat (limited to 'editors/libreoffice')
-rw-r--r--editors/libreoffice/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index b30704c4a262..ecceb75fd119 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -250,7 +250,8 @@ JAVA_CONFIGURE_ON= --enable-ext-wiki-publisher \
--enable-report-builder \
--with-ant-home=${LOCALBASE}/share/java/apache-ant \
--with-jdk-home="${JAVA_HOME}" \
- --with-junit=${JAVAJARDIR}/junit.jar
+ --with-junit=${JAVAJARDIR}/junit.jar \
+ --with-hamcrest=${JAVAJARDIR}/hamcrest.jar
JAVA_CONFIGURE_OFF= --without-java
JAVA_BUILD= yes
JAVA_USE= JAVA=yes