aboutsummaryrefslogtreecommitdiffstats
path: root/editors/libreoffice
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2013-02-16 06:19:09 +0800
committerjkim <jkim@FreeBSD.org>2013-02-16 06:19:09 +0800
commit82f776b80adfca32b605c960ebef684fd77f483f (patch)
tree74a3df01c1d709f061abf7e20f87b18d11d14b5d /editors/libreoffice
parentefd029e7338b1f1a909b08af360329718cfa2c90 (diff)
downloadfreebsd-ports-gnome-82f776b80adfca32b605c960ebef684fd77f483f.tar.gz
freebsd-ports-gnome-82f776b80adfca32b605c960ebef684fd77f483f.tar.zst
freebsd-ports-gnome-82f776b80adfca32b605c960ebef684fd77f483f.zip
- Do not let the configure script guess number of CPUs in the system.
- Honor MAKE_JOBS_NUMBER if available. PR: ports/176177
Diffstat (limited to 'editors/libreoffice')
-rw-r--r--editors/libreoffice/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 3312f82a731c..e4048b3575ca 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -105,6 +105,12 @@ JAVA_DESC= Add java support (XML Filters, macros)
ACLOCAL_ARGS= -I "${WRKSRC}/m4"
+.if defined(DISABLE_MAKE_JOBS)
+MAKE_JOBS_NUMBER= 1
+.else
+MAKE_JOBS_NUMBER?= `${SYSCTL} -n kern.smp.cpus`
+.endif
+
CONFIGURE_ENV= BDB_INCLUDE_DIR=${BDB_INCLUDE_DIR} \
BDB_LIB_DIR=${BDB_LIB_DIR} \
BDB_LIB_NAME=${BDB_LIB_NAME} \
@@ -121,6 +127,7 @@ CONFIGURE_ARGS+= --with-unix-wrapper="libreoffice" \
--exec-prefix=${PREFIX} \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--with-external-tar=${DISTDIR}/${DIST_SUBDIR} \
+ --with-num-cpus=${MAKE_JOBS_NUMBER} \
--with-solver-and-workdir-root=${TMPDIR}/lobuild \
--with-system-boost \
--with-system-clucene \