aboutsummaryrefslogtreecommitdiffstats
path: root/editors/mg
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2001-06-25 01:18:36 +0800
committerdd <dd@FreeBSD.org>2001-06-25 01:18:36 +0800
commit58c7075568a2fdcf4496d3d9a3d72b2cc5a164ed (patch)
tree98f70135e5373c326a3a51d2cfab92fd3660d2b8 /editors/mg
parent825108f9d9348f49d48d15025dbaaddd0f8c35bc (diff)
downloadfreebsd-ports-gnome-58c7075568a2fdcf4496d3d9a3d72b2cc5a164ed.tar.gz
freebsd-ports-gnome-58c7075568a2fdcf4496d3d9a3d72b2cc5a164ed.tar.zst
freebsd-ports-gnome-58c7075568a2fdcf4496d3d9a3d72b2cc5a164ed.zip
Replace the non-scalable way of determining the man page name (the
Makefile in the package honors NOMANCOMPRESS itself) with a much better one mostly suggested by roam@. While I'm here fix my e-mail address.
Diffstat (limited to 'editors/mg')
-rw-r--r--editors/mg/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/editors/mg/Makefile b/editors/mg/Makefile
index 9c0d81f2e92c..d7efbb38baed 100644
--- a/editors/mg/Makefile
+++ b/editors/mg/Makefile
@@ -12,21 +12,26 @@ MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.unixfreak.org/~dima/distfiles/
MASTER_SITE_SUBDIR= dd
-MAINTAINER= dima@unixfreak.org
+MAINTAINER= dd@FreeBSD.org
+MANSECTS= 1
MAN1= mg.1
MANCOMPRESSED= maybe
-# This isn't very scalable, but I'm lazy..
-.if defined(NOMANCOMPRESS)
-MANNAME= mg.1
+# MAN page COMPression SUFFIX
+.if !defined(NOMANCOMPRESS)
+MANCOMPSUFFIX= .gz
.else
-MANNAME= mg.1.gz
+MANCOMPSUFFIX=
.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mg ${PREFIX}/bin/mg
- @${INSTALL_MAN} ${WRKSRC}/${MANNAME} ${PREFIX}/man/man1
+.for __s in ${MANSECTS}
+.for __m in ${MAN${__s}:S/$/${MANCOMPSUFFIX}/}
+ @${INSTALL_MAN} ${WRKSRC}/${__m} ${PREFIX}/man/man${__s}/${__m}
+.endfor
+.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/mg
@${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/tutorial \