aboutsummaryrefslogtreecommitdiffstats
path: root/editors/mule-common
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-05 05:48:51 +0800
committeredwin <edwin@FreeBSD.org>2005-12-05 05:48:51 +0800
commitfc0dc68838a13007fd0b818fc6348a9cb3dfe2b1 (patch)
tree77976100e9bfac0326e786b9307961dc1952ba27 /editors/mule-common
parent2d36bdce1c0646450b91ac24f4148a90a12a4c26 (diff)
downloadfreebsd-ports-gnome-fc0dc68838a13007fd0b818fc6348a9cb3dfe2b1.tar.gz
freebsd-ports-gnome-fc0dc68838a13007fd0b818fc6348a9cb3dfe2b1.tar.zst
freebsd-ports-gnome-fc0dc68838a13007fd0b818fc6348a9cb3dfe2b1.zip
fix packaging on 6.x by carefully removeing info files from the pkg-plist
Diffstat (limited to 'editors/mule-common')
-rw-r--r--editors/mule-common/Makefile8
-rw-r--r--editors/mule-common/pkg-plist112
2 files changed, 63 insertions, 57 deletions
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
index 4c29a3ce147a..469d3814e980 100644
--- a/editors/mule-common/Makefile
+++ b/editors/mule-common/Makefile
@@ -27,6 +27,12 @@ EMACS_VERSION= 19.34
BROKEN= "Does not compile on !i386"
.endif
+.if ${OSVERSION} > 600000
+PLIST_SUB+= NOTON6="@comment "
+.else
+PLIST_SUB+= NOTON6=""
+.endif
+
WRKDIRBASE= ${WRKDIRPREFIX}${.CURDIR:S,/editors/mule-common$,,}
.for dir in chinese/mule-freewnn \
@@ -60,7 +66,7 @@ CONFIGURE_COOKIE= ${WRKDIR}/.configure_done.${MULEPKG}
BUILD_COOKIE= ${WRKDIR}/.build_done.${MULEPKG}
PATCH_COOKIE= ${WRKDIR}/.patch_done.${MULEPKG}
TMPPLIST= ${WRKDIR}/.PLIST.mktmp-${PKGNAME}
-PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
+PLIST_SUB+= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
USE_XLIB= yes
GNU_CONFIGURE= yes
diff --git a/editors/mule-common/pkg-plist b/editors/mule-common/pkg-plist
index 94c93867b86c..cda279ccc366 100644
--- a/editors/mule-common/pkg-plist
+++ b/editors/mule-common/pkg-plist
@@ -36,80 +36,80 @@ bin/rcs-checkin
@comment emacs stuff
@comment
info/ccmode
-info/ccmode-1
-info/ccmode-2
+%%NOTON6%%info/ccmode-1
+%%NOTON6%%info/ccmode-2
info/cl
-info/cl-1
-info/cl-2
-info/cl-3
-info/cl-4
-info/cl-5
-info/cl-6
+%%NOTON6%%info/cl-1
+%%NOTON6%%info/cl-2
+%%NOTON6%%info/cl-3
+%%NOTON6%%info/cl-4
+%%NOTON6%%info/cl-5
+%%NOTON6%%info/cl-6
info/dired-x
info/ediff
-info/ediff-1
-info/ediff-2
+%%NOTON6%%info/ediff-1
+%%NOTON6%%info/ediff-2
info/emacs
info/emacs-1
-info/emacs-10
-info/emacs-11
-info/emacs-12
-info/emacs-13
-info/emacs-14
-info/emacs-15
-info/emacs-16
-info/emacs-17
-info/emacs-18
-info/emacs-19
+%%NOTON6%%info/emacs-10
+%%NOTON6%%info/emacs-11
+%%NOTON6%%info/emacs-12
+%%NOTON6%%info/emacs-13
+%%NOTON6%%info/emacs-14
+%%NOTON6%%info/emacs-15
+%%NOTON6%%info/emacs-16
+%%NOTON6%%info/emacs-17
+%%NOTON6%%info/emacs-18
+%%NOTON6%%info/emacs-19
info/emacs-2
-info/emacs-20
-info/emacs-21
-info/emacs-22
-info/emacs-23
-info/emacs-24
-info/emacs-25
-info/emacs-26
-info/emacs-27
-info/emacs-28
-info/emacs-29
+%%NOTON6%%info/emacs-20
+%%NOTON6%%info/emacs-21
+%%NOTON6%%info/emacs-22
+%%NOTON6%%info/emacs-23
+%%NOTON6%%info/emacs-24
+%%NOTON6%%info/emacs-25
+%%NOTON6%%info/emacs-26
+%%NOTON6%%info/emacs-27
+%%NOTON6%%info/emacs-28
+%%NOTON6%%info/emacs-29
info/emacs-3
info/emacs-4
info/emacs-5
-info/emacs-6
-info/emacs-7
-info/emacs-8
-info/emacs-9
+%%NOTON6%%info/emacs-6
+%%NOTON6%%info/emacs-7
+%%NOTON6%%info/emacs-8
+%%NOTON6%%info/emacs-9
info/forms
info/gnus
info/gnus-1
info/gnus-2
-info/gnus-3
-info/gnus-4
-info/gnus-5
-info/gnus-6
-info/gnus-7
-info/gnus-8
-info/gnus-9
-info/gnus-10
-info/gnus-11
+%%NOTON6%%info/gnus-3
+%%NOTON6%%info/gnus-4
+%%NOTON6%%info/gnus-5
+%%NOTON6%%info/gnus-6
+%%NOTON6%%info/gnus-7
+%%NOTON6%%info/gnus-8
+%%NOTON6%%info/gnus-9
+%%NOTON6%%info/gnus-10
+%%NOTON6%%info/gnus-11
info/message
info/mh-e
-info/mh-e-1
-info/mh-e-2
-info/mh-e-3
-info/mh-e-4
+%%NOTON6%%info/mh-e-1
+%%NOTON6%%info/mh-e-2
+%%NOTON6%%info/mh-e-3
+%%NOTON6%%info/mh-e-4
info/sc
-info/sc-1
-info/sc-2
-info/sc-3
+%%NOTON6%%info/sc-1
+%%NOTON6%%info/sc-2
+%%NOTON6%%info/sc-3
info/vip
-info/vip-1
-info/vip-2
+%%NOTON6%%info/vip-1
+%%NOTON6%%info/vip-2
info/viper
-info/viper-1
-info/viper-2
-info/viper-3
-info/viper-4
+%%NOTON6%%info/viper-1
+%%NOTON6%%info/viper-2
+%%NOTON6%%info/viper-3
+%%NOTON6%%info/viper-4
@comment
@comment mule-specific stuff
@comment