aboutsummaryrefslogtreecommitdiffstats
path: root/editors/mule
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
committerasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
commitaa52cd921c82a10ec33065084fe0edb5cf8bebbc (patch)
treeb70284a297d2e3c06462e3a3a86166c4371477f9 /editors/mule
parentdd1603cad7e60d10dd91a2f1f918e24ed859ed24 (diff)
downloadfreebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.gz
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.zst
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'editors/mule')
-rw-r--r--editors/mule/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index 555dd3db75bc..eaafb5ec72bd 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -3,7 +3,7 @@
# Date created: 6 July 1997
# Whom: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
#
-# $Id: Makefile,v 1.34 1998/12/02 08:40:00 asami Exp $
+# $Id: Makefile,v 1.35 1999/01/23 14:28:25 simokawa Exp $
#
DISTNAME= mule-2.3
@@ -90,10 +90,10 @@ SITE_START=${PREFIX}/share/${EMACS_PREFIX}/19.34/site-lisp/site-start.el
# MEW_ORG_PATCH: apply mew's patches to original mule (http://www.mew.org)
# MEW_PATCH: apply mew's patch after apply Mr. Katayama's patches
post-extract:
- ${EXTRACT_CMD} -C ${WRKDIR} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/mule-2.3-19.34.patch-981002.tar.gz
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/mule-2.3-19.34.patch-981002.tar.gz ${EXTRACT_AFTER_ARGS} -C ${WRKDIR}
${CP} ${FILESDIR}/unexfreebsd.c ${WRKSRC}/src
.if !defined(ORIGINAL) && !defined(MEW_ORG_PATCH)
- ${EXTRACT_CMD} -C ${WRKDIR} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/takana-19.34.tar.gz
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/takana-19.34.tar.gz ${EXTRACT_AFTER_ARGS} -C ${WRKDIR}
${MKDIR} ${WRKSRC}/lisp/its
${CP} ${WRKDIR}/lisp/its/* ${WRKSRC}/lisp/its/
.endif