aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-1.1-devel
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-12-18 11:08:52 +0800
committermaho <maho@FreeBSD.org>2004-12-18 11:08:52 +0800
commitb67aca7414669289f70839cfc1c1f81889c2d7af (patch)
tree2689a85abd53871fc13b69f9caffe7c31fe9a52d /editors/openoffice-1.1-devel
parent5662d4fe44474b8e0b10c4e7d4e0825c2f204bd5 (diff)
downloadfreebsd-ports-gnome-b67aca7414669289f70839cfc1c1f81889c2d7af.tar.gz
freebsd-ports-gnome-b67aca7414669289f70839cfc1c1f81889c2d7af.tar.zst
freebsd-ports-gnome-b67aca7414669289f70839cfc1c1f81889c2d7af.zip
Fix PTHREAD_CFLAGS and PTHREAD_LIBS
hardcoded inside config_office/configure.in
Diffstat (limited to 'editors/openoffice-1.1-devel')
-rw-r--r--editors/openoffice-1.1-devel/files/patch-config_office+configure.in48
1 files changed, 48 insertions, 0 deletions
diff --git a/editors/openoffice-1.1-devel/files/patch-config_office+configure.in b/editors/openoffice-1.1-devel/files/patch-config_office+configure.in
new file mode 100644
index 000000000000..e7ffb67330a6
--- /dev/null
+++ b/editors/openoffice-1.1-devel/files/patch-config_office+configure.in
@@ -0,0 +1,48 @@
+Index: config_office/configure.in
+===================================================================
+RCS file: /cvs/tools/config_office/configure.in,v
+retrieving revision 1.55.6.10
+diff -u -r1.55.6.10 configure.in
+--- config_office/configure.in 27 Aug 2004 10:03:41 -0000 1.55.6.10
++++ config_office/configure.in 18 Dec 2004 03:13:51 -0000
+@@ -357,13 +357,14 @@
+ OSVERSION=`/sbin/sysctl -n kern.osreldate`
+ fi
+ AC_MSG_RESULT([found OSVERSION=$OSVERSION])
+- PTHREAD_CFLAGS="-D_THREAD_SAFE"
+ if test "$OSVERSION" -lt "500016"; then
++ PTHREAD_CFLAGS="-D_THREAD_SAFE"
+ PTHREAD_LIBS="-pthread"
+ elif test "$OSVERSION" -lt "502102"; then
++ PTHREAD_CFLAGS="-D_THREAD_SAFE"
+ PTHREAD_LIBS="-lc_r"
+ else
+- PTHREAD_LIBS="-lpthread"
++ PTHREAD_LIBS="-pthread"
+ fi
+ ;;
+ "OSF1")
+Index: config_office/configure.in
+===================================================================
+RCS file: /cvs/tools/config_office/configure.in,v
+retrieving revision 1.55.6.10
+diff -u -r1.55.6.10 configure.in
+--- config_office/configure.in 27 Aug 2004 10:03:41 -0000 1.55.6.10
++++ config_office/configure.in 18 Dec 2004 03:13:51 -0000
+@@ -357,13 +357,14 @@
+ OSVERSION=`/sbin/sysctl -n kern.osreldate`
+ fi
+ AC_MSG_RESULT([found OSVERSION=$OSVERSION])
+- PTHREAD_CFLAGS="-D_THREAD_SAFE"
+ if test "$OSVERSION" -lt "500016"; then
++ PTHREAD_CFLAGS="-D_THREAD_SAFE"
+ PTHREAD_LIBS="-pthread"
+ elif test "$OSVERSION" -lt "502102"; then
++ PTHREAD_CFLAGS="-D_THREAD_SAFE"
+ PTHREAD_LIBS="-lc_r"
+ else
+- PTHREAD_LIBS="-lpthread"
++ PTHREAD_LIBS="-pthread"
+ fi
+ ;;
+ "OSF1")