aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-3
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-17 11:15:55 +0800
committermaho <maho@FreeBSD.org>2007-01-17 11:15:55 +0800
commitf7587e0dacf834d9a9fa86ec54dc94640d774180 (patch)
treea5c89a62b48cc74e53d4c77210b4b8bc68fee7b0 /editors/openoffice-3
parent91df0541cc47418b5c604c81c305a7583bda9156 (diff)
downloadfreebsd-ports-gnome-f7587e0dacf834d9a9fa86ec54dc94640d774180.tar.gz
freebsd-ports-gnome-f7587e0dacf834d9a9fa86ec54dc94640d774180.tar.zst
freebsd-ports-gnome-f7587e0dacf834d9a9fa86ec54dc94640d774180.zip
RTLD hack is gone for FreeBSD_version >= 602103 (MFC'ed from current)
http://docs.freebsd.org/cgi/mid.cgi?200701160751.l0G7p4gH046864 http://docs.freebsd.org/cgi/mid.cgi?200701160940.l0G9eOQv074301 Submitted by: jkim
Diffstat (limited to 'editors/openoffice-3')
-rw-r--r--editors/openoffice-3/Makefile2
-rw-r--r--editors/openoffice-3/files/patch-i666678
2 files changed, 5 insertions, 5 deletions
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index a2f006a1eef8..dba23424bff1 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -182,7 +182,7 @@ WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif
-.if (${OSVERSION} <= 700021)
+.if (${OSVERSION} <= 602102)
EXTRA_PATCHES+= ${FILESDIR}/rtld-workaround-i66667
.endif
.if (${OSVERSION} <= 492000)
diff --git a/editors/openoffice-3/files/patch-i66667 b/editors/openoffice-3/files/patch-i66667
index a93aaea26176..c1d8cd362e9b 100644
--- a/editors/openoffice-3/files/patch-i66667
+++ b/editors/openoffice-3/files/patch-i66667
@@ -33,7 +33,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-+#if __FreeBSD_version < 700022
++#if __FreeBSD_version < 602103
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
+#else
+ : m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -57,7 +57,7 @@
OString symName( buf.makeStringAndClear() );
-//#iZ 22253
-+#if __FreeBSD_version < 700022 /* #i22253# */
++#if __FreeBSD_version < 602103 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
+#else
+ rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
@@ -117,7 +117,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-+#if __FreeBSD_version < 700022
++#if __FreeBSD_version < 602103
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
+#else
+ : m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -129,7 +129,7 @@
buf.append( 'E' );
OString symName( buf.makeStringAndClear() );
-+#if __FreeBSD_version < 700022 /* #i22253# */
++#if __FreeBSD_version < 602103 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
+#else
+ rtti = (type_info *)dlsym( m_hApp, symName.getStr() );