aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-3
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-07-23 11:47:55 +0800
committermaho <maho@FreeBSD.org>2006-07-23 11:47:55 +0800
commit257ab1ef175388edb7aca26ce60db84ff376a835 (patch)
treeb9dfd42f72d0381ae1abec9e2746bf9fa70f0126 /editors/openoffice-3
parent74225e9682c4e2147d94518f8610f61db5c9df8e (diff)
downloadfreebsd-ports-gnome-257ab1ef175388edb7aca26ce60db84ff376a835.tar.gz
freebsd-ports-gnome-257ab1ef175388edb7aca26ce60db84ff376a835.tar.zst
freebsd-ports-gnome-257ab1ef175388edb7aca26ce60db84ff376a835.zip
Better RUN_DEPENDS section of gcc41-withgcjawt
Diffstat (limited to 'editors/openoffice-3')
-rw-r--r--editors/openoffice-3/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 9707e4a0e4f1..0336c917026c 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -92,17 +92,16 @@ PKGNAMESUFFIX?= -${LANG_SUFFIX}
.endif
.if defined(WITH_GNUGCJ)
-#this wired part must be rewritten
-GCCVER=4.1.2
-BUILD_DEPENDS+= ${PREFIX}/lib/gcc/${GCC_TARGET}/${GCCVER}/lib-gnu-java-awt-peer-gtk.so:${PORTSDIR}/lang/gcc41-withgcjawt
+GCCVER=41
+BUILD_DEPENDS+= ${PREFIX}/libdata/ldconfig/gcc41-withgcjawt:${PORTSDIR}/lang/gcc41-withgcjawt
BUILD_DEPENDS+= gjdoc:${PORTSDIR}/java/gjdoc
-RUN_DEPENDS+= ${PREFIX}/lib/gcc/${GCC_TARGET}/${GCCVER}/lib-gnu-java-awt-peer-gtk.so:${PORTSDIR}/lang/gcc41-withgcjawt
+RUN_DEPENDS+= ${PREFIX}/libdata/ldconfig/gcc41-withgcjawt:${PORTSDIR}/lang/gcc41-withgcjawt
.else
.if ${ARCH} == amd64
-GCCVER=4.1.2
+GCCVER=41
BUILD_DEPENDS+= gcc41:${PORTSDIR}/lang/gcc41
.else
-GCCVER=3.4.1
+GCCVER=34
BUILD_DEPENDS+= gcc-ooo:${PORTSDIR}/lang/gcc-ooo
.endif
.endif
@@ -113,11 +112,11 @@ CCACHE_PREFIX= ccache
.else
CCACHE_PREFIX=
.endif
-.if (${GCCVER} == 4.1.2)
+.if (${GCCVER} == 41)
CC= gcc41
CXX= g++41
.endif
-.if (${GCCVER} == 3.4.1)
+.if (${GCCVER} == 34)
CC= gcc-ooo
CXX= g++-ooo
.endif
@@ -160,7 +159,7 @@ CONFIGURE_ARGS+= --with-system-freetype #link error with internal one
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
.endif
-.if (${GCCVER} == 4.1.2)
+.if (${GCCVER} == 41)
LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif