aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-3
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2011-11-06 10:43:14 +0800
committermaho <maho@FreeBSD.org>2011-11-06 10:43:14 +0800
commit6ee97bdab1d650398b678f3d33360f9ff1bd6d6d (patch)
tree11f5f0e82c7933fbbf78007b13436f199d06ec96 /editors/openoffice-3
parent519fb0aa5900c6ff40ff7a944c7d529d77781158 (diff)
downloadfreebsd-ports-gnome-6ee97bdab1d650398b678f3d33360f9ff1bd6d6d.tar.gz
freebsd-ports-gnome-6ee97bdab1d650398b678f3d33360f9ff1bd6d6d.tar.zst
freebsd-ports-gnome-6ee97bdab1d650398b678f3d33360f9ff1bd6d6d.zip
Fix build for vcl [1] and Python.
PR: 161789 [1] Submitted by: Pim van Grol [1]
Diffstat (limited to 'editors/openoffice-3')
-rw-r--r--editors/openoffice-3/files/patch-python-2.6.2-svnversion53
-rw-r--r--editors/openoffice-3/files/patch-vcl-PR16178922
2 files changed, 75 insertions, 0 deletions
diff --git a/editors/openoffice-3/files/patch-python-2.6.2-svnversion b/editors/openoffice-3/files/patch-python-2.6.2-svnversion
new file mode 100644
index 000000000000..5006464fe0f3
--- /dev/null
+++ b/editors/openoffice-3/files/patch-python-2.6.2-svnversion
@@ -0,0 +1,53 @@
+http://bugs.python.org/file14047
+
+--- python/Python-2.6.1.patch~ 2011-11-06 00:03:55.000000000 +0900
++++ python/Python-2.6.1.patch 2011-11-06 07:51:41.000000000 +0900
+@@ -1,3 +1,48 @@
++--- misc/Python-2.6.1/configure.in Wed Jun 11 09:41:16 2008
+++++ misc/build/Python-2.6.1/configure.in Fri Apr 17 09:02:52 2009
++@@ -767,7 +767,7 @@
++ then
++ SVNVERSION="svnversion \$(srcdir)"
++ else
++- SVNVERSION="echo exported"
+++ SVNVERSION="echo Unversioned directory"
++ fi
++
++ case $MACHDEP in
++--- misc/Python-2.6.1/Makefile.pre.in Wed Jun 11 09:41:16 2008
+++++ misc/build/Python-2.6.1/Makefile.pre.in Fri Apr 17 09:02:52 2009
++@@ -501,7 +501,7 @@
++ $(SIGNAL_OBJS) \
++ $(MODOBJS) \
++ $(srcdir)/Modules/getbuildinfo.c
++- $(CC) -c $(PY_CFLAGS) -DSVNVERSION=\"`LC_ALL=C $(SVNVERSION)`\" -o $@ $(srcdir)/Modules/getbuildinfo.c
+++ $(CC) -c $(PY_CFLAGS) -DSVNVERSION="\"`LC_ALL=C $(SVNVERSION)`\"" -o $@ $(srcdir)/Modules/getbuildinfo.c
++
++ Modules/getpath.o: $(srcdir)/Modules/getpath.c Makefile
++ $(CC) -c $(PY_CFLAGS) -DPYTHONPATH='"$(PYTHONPATH)"' \
++--- misc/Python-2.6.1/Modules/getbuildinfo.c Wed Jun 11 09:41:16 2008
+++++ misc/build/Python-2.6.1/Modules/getbuildinfo.c Fri Apr 17 09:02:52 2009
++@@ -48,5 +48,5 @@
++ static const char svnversion[] = SVNVERSION;
++ if (svnversion[0] != '$')
++ return svnversion; /* it was interpolated, or passed on command line */
++- return "exported";
+++ return "Unversioned directory";
++ }
++--- misc/Python-2.6.1/Python/sysmodule.c Wed Jun 11 09:41:16 2008
+++++ misc/build/Python-2.6.1/Python/sysmodule.c Fri Apr 17 09:02:52 2009
++@@ -1161,7 +1161,7 @@
++
++
++ svnversion = _Py_svnversion();
++- if (strcmp(svnversion, "exported") != 0)
+++ if (strcmp(svnversion, "Unversioned directory") != 0 && strcmp(svnversion, "exported") != 0)
++ svn_revision = svnversion;
++ else if (istag) {
++ len = strlen(_patchlevel_revision);
++
++
++
+ --- misc/Python-2.6.1/Include/pyport.h Wed Jun 11 09:41:16 2008
+ +++ misc/build/Python-2.6.1/Include/pyport.h Fri Apr 17 09:02:52 2009
+ @@ -449,11 +449,6 @@
diff --git a/editors/openoffice-3/files/patch-vcl-PR161789 b/editors/openoffice-3/files/patch-vcl-PR161789
new file mode 100644
index 000000000000..3ce115c46d94
--- /dev/null
+++ b/editors/openoffice-3/files/patch-vcl-PR161789
@@ -0,0 +1,22 @@
+--- vcl/unx/inc/xfont.hxx~ 2011-01-18 22:35:50.000000000 +0900
++++ vcl/unx/inc/xfont.hxx 2011-11-06 07:38:40.000000000 +0900
+@@ -27,7 +27,7 @@
+ #ifndef EXTENDED_FONTSTRUCT_HXX
+ #define EXTENDED_FONTSTRUCT_HXX
+
+-#ifndef _XLIB_H_
++#ifndef _X11_XLIB_H_
+ #include <tools/prex.h>
+ #include <X11/Xlib.h>
+ #include <tools/postx.h>
+--- vcl/unx/inc/dtint.hxx~ 2011-01-18 22:35:50.000000000 +0900
++++ vcl/unx/inc/dtint.hxx 2011-11-06 07:38:23.000000000 +0900
+@@ -36,7 +36,7 @@
+ class SalDisplay;
+ class AllSettings;
+
+-#ifndef _XLIB_H_
++#ifndef _X11_XLIB_H_
+ // forwards from X
+ struct Display;
+ struct XEvent;