aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-3
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-03-05 23:52:12 +0800
committermbr <mbr@FreeBSD.org>2002-03-05 23:52:12 +0800
commit0d55678274b144e20e256c12c7a78310825efc35 (patch)
tree335a15e3ccc4b9908fb571fa3bbd9057f2f68d75 /editors/openoffice-3
parentac71c656413fe746f5e0c5275b94e32a7d780729 (diff)
downloadfreebsd-ports-gnome-0d55678274b144e20e256c12c7a78310825efc35.tar.gz
freebsd-ports-gnome-0d55678274b144e20e256c12c7a78310825efc35.tar.zst
freebsd-ports-gnome-0d55678274b144e20e256c12c7a78310825efc35.zip
Fix tar.gz extraction. Our tar seems not to like the included tar files and exits
with error value 141. But only if the gunzip stream is redirected from STDIN. If our tar is used with -z, everything works. Looks like a BSD tar bug.
Diffstat (limited to 'editors/openoffice-3')
-rw-r--r--editors/openoffice-3/files/patch-solenv+inc+tg_ext.mk9
-rw-r--r--editors/openoffice-3/files/patch-solenv::inc::tg_ext.mk9
2 files changed, 18 insertions, 0 deletions
diff --git a/editors/openoffice-3/files/patch-solenv+inc+tg_ext.mk b/editors/openoffice-3/files/patch-solenv+inc+tg_ext.mk
index 5ce29de2a669..039af7d70871 100644
--- a/editors/openoffice-3/files/patch-solenv+inc+tg_ext.mk
+++ b/editors/openoffice-3/files/patch-solenv+inc+tg_ext.mk
@@ -1,5 +1,14 @@
--- ../solenv/inc/tg_ext.mk.orig Wed Nov 14 13:59:42 2001
+++ ../solenv/inc/tg_ext.mk Mon Mar 4 17:30:39 2002
+@@ -107,7 +107,7 @@
+
+ $(MISC)$/%.unpack : $(PRJ)$/download$/%.tar.gz
+ @+-$(RM) $@
+- @+echo $(assign UNPACKCMD := gunzip -c $(BACK_PATH)download$/$(TARFILE_NAME).tar.gz | tar $(TAR_EXCLUDE_SWITCH) -xvf - ) > $(NULLDEV)
++ @+echo $(assign UNPACKCMD := tar $(TAR_EXCLUDE_SWITCH) -xzvf $(BACK_PATH)download$/$(TARFILE_NAME).tar.gz ) > $(NULLDEV)
+ @+$(COPY) $(mktmp $(UNPACKCMD)) $@
+
+ $(MISC)$/%.unpack : $(PRJ)$/download$/%.tar
@@ -148,7 +148,11 @@
.IF "$(BSCLIENT)"=="TRUE"
+cd $(PACKAGE_DIR) && $(TYPE) $(BACK_PATH)$(PATCH_FILE_NAME) | $(GNUPATCH) -f -b -p2 && $(TOUCH) $(PATCH_FLAG_FILE)
diff --git a/editors/openoffice-3/files/patch-solenv::inc::tg_ext.mk b/editors/openoffice-3/files/patch-solenv::inc::tg_ext.mk
index 5ce29de2a669..039af7d70871 100644
--- a/editors/openoffice-3/files/patch-solenv::inc::tg_ext.mk
+++ b/editors/openoffice-3/files/patch-solenv::inc::tg_ext.mk
@@ -1,5 +1,14 @@
--- ../solenv/inc/tg_ext.mk.orig Wed Nov 14 13:59:42 2001
+++ ../solenv/inc/tg_ext.mk Mon Mar 4 17:30:39 2002
+@@ -107,7 +107,7 @@
+
+ $(MISC)$/%.unpack : $(PRJ)$/download$/%.tar.gz
+ @+-$(RM) $@
+- @+echo $(assign UNPACKCMD := gunzip -c $(BACK_PATH)download$/$(TARFILE_NAME).tar.gz | tar $(TAR_EXCLUDE_SWITCH) -xvf - ) > $(NULLDEV)
++ @+echo $(assign UNPACKCMD := tar $(TAR_EXCLUDE_SWITCH) -xzvf $(BACK_PATH)download$/$(TARFILE_NAME).tar.gz ) > $(NULLDEV)
+ @+$(COPY) $(mktmp $(UNPACKCMD)) $@
+
+ $(MISC)$/%.unpack : $(PRJ)$/download$/%.tar
@@ -148,7 +148,11 @@
.IF "$(BSCLIENT)"=="TRUE"
+cd $(PACKAGE_DIR) && $(TYPE) $(BACK_PATH)$(PATCH_FILE_NAME) | $(GNUPATCH) -f -b -p2 && $(TOUCH) $(PATCH_FLAG_FILE)