aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2018-01-20 03:40:46 +0800
committertruckman <truckman@FreeBSD.org>2018-01-20 03:40:46 +0800
commit5cfeeebeed9f72fa2abc14ede54630aede12e75b (patch)
treef7a6d64befe72761601c8df294bb6f244299bd0b /editors/openoffice-4
parent552bf7f2678db687972fdbd42f8ffb2b0eb53913 (diff)
downloadfreebsd-ports-gnome-5cfeeebeed9f72fa2abc14ede54630aede12e75b.tar.gz
freebsd-ports-gnome-5cfeeebeed9f72fa2abc14ede54630aede12e75b.tar.zst
freebsd-ports-gnome-5cfeeebeed9f72fa2abc14ede54630aede12e75b.zip
Remove the CCACHE option and other ccache code from the Makefile
and use the ccache code in the ports framework handle all of the details. Don't prepend ${WRKSRC}/solenv/bin to PATH in CONFIGURE_ENV since it is no longer needed and blocks the framework from adding CCACHE_WRAPPER_PATH to PATH in CONFIGURE_ENV and MAKE_ENV. Sanitize MAKE_ENV and export its to the build, similar to what is done by the default do-build target. This passes CCACHE_DIR and HOME (set to WRKDIR) to the build, so the $HOME override in r459316 is no longer needed. We need to remove the CPPFLAGS setting from MAKE_ENV before exporting to the build because it breaks the build of the bundled icu module. CFLAGS and CXXFLAGS are also removed because they would interfere with the carefully constructed compiler flags set by the port. The include paths are already handled by the port, and the port also modifies the optmization flags for some files to work around compiler bugs. While here, remove files/ooo.sh files/generate.pl since they have been obsolete for a long while. No PORTREVISION bump since the package should be unchanged. PR: 224276
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile20
-rw-r--r--editors/openoffice-4/files/generate.pl40
-rw-r--r--editors/openoffice-4/files/ooo.sh43
3 files changed, 3 insertions, 100 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index d39826c281d3..82ed48bc8942 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -138,14 +138,13 @@ WITHOUT_CPU_CFLAGS= true
CPE_PRODUCT= ${PORTNAME:S|apache-||}
CPE_VENDOR= apache
-OPTIONS_DEFINE= CUPS GNOME GNOMEVFS MMEDIA SDK WIKI_PUBLISHER CCACHE
+OPTIONS_DEFINE= CUPS GNOME GNOMEVFS MMEDIA SDK WIKI_PUBLISHER
OPTIONS_DEFAULT= CUPS GNOME GNOMEVFS MMEDIA WIKI_PUBLISHER
GNOME_DESC= GConf + screensaver presentation control via DBUS
GNOMEVFS_DESC= GNOME Virtual File System
MMEDIA_DESC= Multimedia backend for impress
SDK_DESC= Build and install software development kit
WIKI_PUBLISHER_DESC= Build and install Wiki Publisher extension
-CCACHE_DESC= Mimimize compile time of C/C++ programs
CUPS_CONFIGURE_ENABLE= cups
CUPS_LIB_DEPENDS= libcups.so:print/cups
@@ -207,18 +206,7 @@ PACKAGE_PREFIX= Apache_OpenOffice
LOCALIZED_LANG?= en-US
-.if ${PORT_OPTIONS:MCCACHE} || defined(WITH_CCACHE)
-BUILD_DEPENDS+= ccache:devel/ccache
-CCACHE_PREFIX= ccache
-AOOCC= ${CCACHE_PREFIX} ${CC}
-AOOCXX= ${CCACHE_PREFIX} ${CXX}
-.else
-AOOCC= ${CC}
-AOOCXX= ${CXX}
-.endif
-
-CONFIGURE_ENV+= CC="${AOOCC}" CXX="${AOOCXX}" \
- PATH=${WRKSRC}/solenv/bin:$$PATH
+AOO_MAKE_ENV= ${MAKE_ENV:NCPPFLAGS=*:NCFLAGS=*:NCXXFLAGS=*}
GNU_CONFIGURE= yes
WRKSUBDIR= ${WRKDIR}/aoo-${AOOVERSION}
@@ -415,10 +403,8 @@ do-build:
fi ; \
fi ; \
cd ${WRKSRC}/instsetoo_native ; \
+ export ${AOO_MAKE_ENV} ; \
. ../${FREEBSD_ENV_SET} ; \
- if [ -n "${HOME}" -a ! -w "${HOME}" ]; then \
- export HOME=/tmp ; \
- fi ; \
build.pl --all -P$${numproc} -- -P$${dmproc}
do-install:
diff --git a/editors/openoffice-4/files/generate.pl b/editors/openoffice-4/files/generate.pl
deleted file mode 100644
index d5871e7b2550..000000000000
--- a/editors/openoffice-4/files/generate.pl
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/perl
-# generate full build shell script for Apache OpenOffice
-# Whom: Maho Nakata <maho@FreeBSD.org>
-# $FreeBSD: /tmp/pcvs/ports/editors/openoffice-3/files/generate.pl,v 1.15 2012-05-09 03:48:16 maho Exp $
-
-print "#!/bin/csh\n";
-print "make deinstall clean\n";
-print "/usr/bin/time -h make WITH_CCACHE=yes install package package-rename solver sdk ure languagepack deinstall >& log.en\n";
-print "bzip2 log.en\n";
-#print "rm work/.configure* work/.build* \n";
-#workaround for breakage at odk sdk_oo
-print "make deinstall clean\n";
-
-print "/usr/bin/time -h make ALL_LOCALIZED_LANGS=yes >& log.all\n";
-print "bzip2 log.all\n";
-
-open ( FILE, "< Makefile.localized") ;
-while(<FILE>){
-@tmp=split (' ',$_);
-@tmp2=split ('"',$tmp[3]);
-if ( $tmp[0] eq ".if" && $tmp[1] eq "\${LOCALIZED_LANG}" ) { $LANG=$tmp2[1];
- print "make TWEAK_L10N=yes LOCALIZED_LANG=$LANG pre-everything\n";
- print "/usr/bin/time -h make LOCALIZED_LANG=$LANG WITH_CCACHE=yes languagepack package package-rename deinstall >& log.$LANG\n";
- print "bzip2 log.$LANG\n";
- }
-}
-close FILE;
-$oootag= `cd ..; make -V OOOTAG2`;
-chomp($oootag);
-$md5sumname = "$oootag" . "_md5sums.txt";
-print "md5 OOo* > $md5sumname\n";
-
-$arc= `uname -m`;
-if ($arc == "amd64" ) {
-print "sudo -u `who am i | awk '{print \$1}'` ssh build.good-day.net mkdir -p /home/ftp/pub/OpenOffice.org/contrib/freebsdx86-64/\n";
-print "sudo -u `who am i | awk '{print \$1}'` scp OOo* $md5sumname build.good-day.net:/home/ftp/pub/OpenOffice.org/contrib/freebsdx86-64/\n";
-} else {
-print "sudo -u `who am i | awk '{print \$1}'` ssh build.good-day.net mkdir -p /home/ftp/pub/OpenOffice.org/contrib/freebsdx86/\n";
-print "sudo -u `who am i | awk '{print \$1}'` scp OOo* $md5sumname build.good-day.net:/home/ftp/pub/OpenOffice.org/contrib/freebsdx86/\n";
-}
diff --git a/editors/openoffice-4/files/ooo.sh b/editors/openoffice-4/files/ooo.sh
deleted file mode 100644
index 8f0ffbde843f..000000000000
--- a/editors/openoffice-4/files/ooo.sh
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-# Openoffice.org build and uploader for FreeBSD.
-# Nakata Maho (maho@FreeBSD.org) 2010/2/13.
-# this file is public domain.
-# $Id$
-
-MILESTONE=`make -V OOOTAG`
-fbsdmajor=`uname -r | sed 's/\..*$//g'`
-fbsdarch=`uname -m`
-OOODIR=/home/ftp/pub/OpenOffice.org/FreeBSD/packages-$fbsdmajor-$fbsdarch
-SITE=build.good-day.net
-USER=maho
-
-#build
-/usr/bin/time -h sudo -u $USER make WITH_CCACHE=yes >log.en.$MILESTONE 2>&1
-/usr/bin/time -h make deinstall package package-rename >> log.en.$MILESTONE 2>&1
-/usr/bin/time -h make sdk ure >> log.en.$MILESTONE 2>&1
-/usr/bin/time -h make deinstall >> log.en.$MILESTONE 2>&1
-
-/usr/bin/time -h make clean >log.ja.$MILESTONE 2>&1
-/usr/bin/time -h sudo -u $USER make LOCALIZED_LANG=ja WITH_CCACHE=yes >log.ja.$MILESTONE 2>&1
-/usr/bin/time -h make LOCALIZED_LANG=ja deinstall package package-rename languagepack >> log.ja.$MILESTONE 2>&1
-/usr/bin/time -h make LOCALIZED_LANG=ja deinstall >> log.ja.$MILESTONE 2>&1
-
-OOOENUSPACKAGE1=`ls openoffice.org*tbz`
-OOOENUSPACKAGE2=`ls OOo*install_en-US.tbz`
-OOOJAPACKAGE1=`ls ja-openoffice.org*tbz`
-OOOJAPACKAGE2=`ls OOo*install_ja.tbz`
-
-#upload
-bzip2 log.en.$MILESTONE log.ja.$MILESTONE
-sudo -u $USER ssh $SITE mkdir $OOODIR
-sudo -u $USER scp *openoffice*.tbz *SDK* *URE* log.* $SITE:$OOODIR
-
-if [ x$OOOENUSPACKAGE1 != x"" ]; then
-sudo -u $USER ssh $SITE "ln -sf $OOODIR/$OOOENUSPACKAGE1 $OOODIR/$OOOENUSPACKAGE2"
-fi
-if [ x$OOOJAPACKAGE1 != x"" ]; then
-sudo -u $USER ssh $SITE "ln -sf $OOODIR/$OOOJAPACKAGE1 $OOODIR/$OOOJAPACKAGE2"
-fi
-
-
-