aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2018-04-19 05:06:00 +0800
committertruckman <truckman@FreeBSD.org>2018-04-19 05:06:00 +0800
commit8795486fcd61f90e1ebac336abaa05f914ba93e7 (patch)
tree3ae7419a100c99579ea8d51325720b930426bce8 /editors/openoffice-4
parentab73b5027b75569e4b8905bcc9767c5afd7efd49 (diff)
downloadfreebsd-ports-gnome-8795486fcd61f90e1ebac336abaa05f914ba93e7.tar.gz
freebsd-ports-gnome-8795486fcd61f90e1ebac336abaa05f914ba93e7.tar.zst
freebsd-ports-gnome-8795486fcd61f90e1ebac336abaa05f914ba93e7.zip
Fix editors/openoffice-4 build with boost 1.67 by checking the boost
version and including <boost/next_prior.hpp> instead of <boost/utility.hpp> when the new version of boost is detected. PR: 227553 Reported by: jbeich
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile1
-rw-r--r--editors/openoffice-4/files/patch-boost1.6736
2 files changed, 36 insertions, 1 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 0a1097945e17..30426a721a1e 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -48,7 +48,6 @@ LICENSE_PERMS_TWAIN= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_W3C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
ONLY_FOR_ARCHS= amd64 i386 powerpc64
-BROKEN= fails to build with boost 1.67, see bug 227553
BUILD_DEPENDS= \
p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
diff --git a/editors/openoffice-4/files/patch-boost1.67 b/editors/openoffice-4/files/patch-boost1.67
new file mode 100644
index 000000000000..9965702c81dc
--- /dev/null
+++ b/editors/openoffice-4/files/patch-boost1.67
@@ -0,0 +1,36 @@
+Index: basegfx/source/range/b2drangeclipper.cxx
+===================================================================
+--- basegfx/source/range/b2drangeclipper.cxx (revision 1829412)
++++ basegfx/source/range/b2drangeclipper.cxx (working copy)
+@@ -35,7 +35,12 @@
+
+ #include <o3tl/vector_pool.hxx>
+ #include <boost/bind.hpp>
+-#include <boost/utility.hpp>
++#include <boost/version.hpp>
++#if BOOST_VERSION < 106700
++# include <boost/utility.hpp>
++#else
++# include <boost/next_prior.hpp>
++#endif
+
+ #include <algorithm>
+ #include <deque>
+Index: slideshow/source/inc/listenercontainer.hxx
+===================================================================
+--- slideshow/source/inc/listenercontainer.hxx (revision 1829412)
++++ slideshow/source/inc/listenercontainer.hxx (working copy)
+@@ -24,7 +24,12 @@
+ #define INCLUDED_SLIDESHOW_LISTENERCONTAINER_HXX
+
+ #include <osl/mutex.hxx>
+-#include <boost/utility.hpp>
++#include <boost/version.hpp>
++#if BOOST_VERSION < 106700
++# include <boost/utility.hpp>
++#else
++# include <boost/next_prior.hpp>
++#endif
+ #include <algorithm>
+ #include <vector>
+