aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice.org-3-RC
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2003-03-27 17:41:44 +0800
committermbr <mbr@FreeBSD.org>2003-03-27 17:41:44 +0800
commit06b64e4e1e0573b6d3ad18593be27e869af45fb7 (patch)
tree0328b98c8a9c638df52c9f1dfb2c462fdbabfdeb /editors/openoffice.org-3-RC
parent0dbac47553374df456b0320905e7336b28a0ce91 (diff)
downloadfreebsd-ports-gnome-06b64e4e1e0573b6d3ad18593be27e869af45fb7.tar.gz
freebsd-ports-gnome-06b64e4e1e0573b6d3ad18593be27e869af45fb7.tar.zst
freebsd-ports-gnome-06b64e4e1e0573b6d3ad18593be27e869af45fb7.zip
OOo1.1 seems to link against a lib in the jdk. OOo will still run
without this library, but for compile it is definitly needed. Remove the linux jdk dependency and use again our native one.
Diffstat (limited to 'editors/openoffice.org-3-RC')
-rw-r--r--editors/openoffice.org-3-RC/Makefile22
1 files changed, 1 insertions, 21 deletions
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index c10f8d2b70b8..872c471253ab 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -118,11 +118,7 @@ COMMENT= Integrated wordprocessor/dbase/spreadheet/drawing/chart/browser
# The JDK dependency needs to be at the first place, so all
# following dependencies use the same JDK.
#
-.if !defined(WITH_BSD_JDK)
-BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/linux-sun-jdk14
-.else
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
-.endif
#.if !defined(USE_GCC)
#BUILD_DEPENDS= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
@@ -145,11 +141,7 @@ EXTRACT_AFTER_ARGS_R= | ${TAR} -xf -
EXTRACT_CMD_R= ${GZIP_CMD}
EXTRACT_REST= gpc231.tar.Z
-.if !defined(WITH_BSD_JDK)
-JDKDIR?= ${LOCALBASE}/linux-sun-jdk1.4.1
-.else
-JDKDIR?= ${LOCALBASE}/jdk1.4.1
-.endif
+JDKDIR= ${LOCALBASE}/jdk1.4.1
JAVAVM= ${JDKDIR}/bin/java
GNU_CONFIGURE= yes
@@ -184,10 +176,6 @@ CONFIGURE_ARGS+= --with-jdk-home=${JDKDIR} \
#CONFIGURE_ARGS+= --with-stlport4-home=${PREFIX}
#.endif
-.if !defined(WITH_BSD_JDK)
-CONFIGURE_ARGS+= --enable-linuxjdk=yes
-.endif
-
.if defined(WITH_DEBUG)
.if ${WITH_DEBUG} == 2
CONFIGURE_ARGS+= --enable-debug
@@ -236,14 +224,6 @@ pre-fetch:
@${ECHO} "to compile openoffice with your"
@${ECHO} "prefered compiler."
.endif
-.if !defined(WITH_BSD_JDK)
- @${ECHO}
- @${ECHO} "If you like to use the native BSD"
- @${ECHO} "JDK for the build system, you can use"
- @${ECHO} "WITH_BSD_JDK=TRUE to disable the"
- @${ECHO} "usage of the linux-JDK and linux dependency."
- @${ECHO}
-.endif
.if !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "You can compile OO with debug symbols"