aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice.org-3-RC
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-05-09 09:04:50 +0800
committermaho <maho@FreeBSD.org>2006-05-09 09:04:50 +0800
commit82d0dd5d1e489686f1d2ab83d1bc68663142355b (patch)
treea99fab18ccde774b42f4b2bdfad04501e3e16349 /editors/openoffice.org-3-RC
parent6f9777b0d332e393d5e370c3fdcddc240905feec (diff)
downloadfreebsd-ports-gnome-82d0dd5d1e489686f1d2ab83d1bc68663142355b.tar.gz
freebsd-ports-gnome-82d0dd5d1e489686f1d2ab83d1bc68663142355b.tar.zst
freebsd-ports-gnome-82d0dd5d1e489686f1d2ab83d1bc68663142355b.zip
Automatically fixup the *.desktop files and hook them into KDE
Submitted by: jhb
Diffstat (limited to 'editors/openoffice.org-3-RC')
-rw-r--r--editors/openoffice.org-3-RC/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 12e8dbb3da1f..fef60b1fd2cf 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -158,6 +158,8 @@ EXTRA_PATCHES+= ${FILESDIR}/moz-patch_i59729 #cws pj50
#EXTRA_PATCHES+= ${FILESDIR}/optpatch-freetype
#.endif
+ICONS= ${WRKSRC}/sysui/desktop/icons
+
.include <${FILESDIR}/Makefile.knobs>
pre-everything::
@@ -237,6 +239,29 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
@${PRINTF} "bin/openoffice.org\n" > ${TMPPLIST}
+ @${REINPLACE_CMD} -e 's#${RELEASE_NR}#${OOOVERSION}#g' \
+ -e '/^Exec/s/printeradmin/spadmin/' \
+ ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
+ @${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
+.if defined(WITH_KDE)
+ @ln -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
+ ${PREFIX}/share/applnk/${EXECBASE}
+ @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+.endif
+ @for dir in `ls ${ICONS}/hicolor | grep -v CVS`; do \
+ for app in base calc draw impress math printeradmin writer; do \
+ if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
+ ${CP} ${ICONS}/hicolor/$${dir}/apps/$${app}.png \
+ ${PREFIX}/share/icons/hicolor/$${dir}/apps/openofficeorg-20-$${app}.png ; \
+ ${PRINTF} "share/icons/hicolor/$${dir}/apps/openofficeorg-20-$${app}.png\n" >> ${TMPPLIST} ; \
+ fi \
+ done ; \
+ for file in `cd ${ICONS}/hicolor/$${dir}/mimetypes; ls *.png`; do \
+ ${CP} ${ICONS}/hicolor/$${dir}/mimetypes/$${file} \
+ ${PREFIX}/share/icons/hicolor/$${dir}/mimetypes/ ; \
+ ${PRINTF} "share/icons/hiclor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
+ done ; \
+ done
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}