aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice/Makefile
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-06-07 23:24:41 +0800
committermbr <mbr@FreeBSD.org>2002-06-07 23:24:41 +0800
commitff345c0864e14a6fbeb864cc4d6aed19ad8e3b38 (patch)
treef7e3d7ffdf53d375bbf40d9007e14308404ed3b0 /editors/openoffice/Makefile
parent2907f133d90f9c5a21534a0bedc681a65252764d (diff)
downloadfreebsd-ports-gnome-ff345c0864e14a6fbeb864cc4d6aed19ad8e3b38.tar.gz
freebsd-ports-gnome-ff345c0864e14a6fbeb864cc4d6aed19ad8e3b38.tar.zst
freebsd-ports-gnome-ff345c0864e14a6fbeb864cc4d6aed19ad8e3b38.zip
- Dependency fix.
- Really build OO on CURRENT with g++ from ports
Diffstat (limited to 'editors/openoffice/Makefile')
-rw-r--r--editors/openoffice/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index c28f31c6f6ca..409937b58440 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -28,6 +28,14 @@ USE_GCC=3.1
.endif
.if ${OSVERSION} > 500000
+.if ${USE_GCC} == 3.1
+#
+# We depend on the port. System g++ is broken at the moment.
+#
+BUILD_DEPENDS+= gcc31:${PORTSDIR}/lang/gcc31
+CC= gcc31
+CXX= g++31
+.endif
.if defined(USE_GCC) && ${USE_GCC} == 2.95
MOZILLADIST= oo_moz1.0RC3_${ARCH}_FreeBSD-5-gcc2.95-ports.tar.gz
.else
@@ -50,7 +58,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake-4
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
LIB_DEPENDS+= pth.14:${PORTSDIR}/devel/pth
USE_PERL5= yes