aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-05-20 00:26:14 +0800
committermbr <mbr@FreeBSD.org>2002-05-20 00:26:14 +0800
commit89f55f65585e46b9ff4ab8811c117f2cd1fe44eb (patch)
tree476f78791fe6c36e60a1dc42924b4515cd7335d2 /editors/openoffice
parent17f99277fc167a63a121c27752c894b4d1322c53 (diff)
downloadfreebsd-ports-gnome-89f55f65585e46b9ff4ab8811c117f2cd1fe44eb.tar.gz
freebsd-ports-gnome-89f55f65585e46b9ff4ab8811c117f2cd1fe44eb.tar.zst
freebsd-ports-gnome-89f55f65585e46b9ff4ab8811c117f2cd1fe44eb.zip
Fix the last commit. Since OO was only compileable in a little
timeframe on CURRENT, mark it broken for all CURRENT versions. Beside that, the logic was wrong.
Diffstat (limited to 'editors/openoffice')
-rw-r--r--editors/openoffice/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 28840ad21534..11158a972fda 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -52,9 +52,9 @@ CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
.include <bsd.port.pre.mk>
pre-fetch:
-.if ${OSVERSION} > 500034 || ${OSVERSION} < 500034
+.if ${OSVERSION} > 500000
@${ECHO}
- @${ECHO} OS-VERSION ${OSVERSION}
+ @${ECHO} OS-VERSION ${OSVERSION} too high
@${ECHO}
@${ECHO} Openoffice is currently broken on CURRENT and does
@${ECHO} not yet work with GCC 3.1
@@ -64,12 +64,13 @@ pre-fetch:
@${ECHO}
@${FALSE}
.endif
-.if ${OSVERSION} < 450002
+.if ${OSVERSION} < 450005
@${ECHO}
- @${ECHO} OS-VERSION ${OSVERSION}
+ @${ECHO} OS-VERSION ${OSVERSION} too low
@${ECHO}
@${ECHO} Openoffice need some important libc_r and
- @${ECHO} gcc fixes to build. Please upgrade.
+ @${ECHO} gcc fixes to build. Please upgrade to 4.6
+ @${ECHO} PRE-RELEASE or RELEASE.
@${FALSE}
.endif
.if ${GCC_VERSION}!="2.95.2" && ${GCC_VERSION}!="2.95.3" && ${GCC_VERSION}!="2.95.4"
@@ -94,8 +95,8 @@ pre-extract:
@${ECHO} settings and add this to your KERNEL
@${ECHO} configuration if necessary:
@${ECHO}
- @${ECHO} options MAXDSIZ="(1024*1024*1024)"
- @${ECHO} options MAXSSIZ="(256*1024*1024)"
+ @${ECHO} options MAXDSIZ=\"\(1024*1024*1024\)\"
+ @${ECHO} options MAXSSIZ=\"\(256*1024*1024\)\"
@${ECHO}
.if !defined(DISPLAY) || ${DISPLAY} == ""
@ ${ECHO}