aboutsummaryrefslogtreecommitdiffstats
path: root/editors/pdfedit
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-07-03 02:25:46 +0800
committermiwi <miwi@FreeBSD.org>2011-07-03 02:25:46 +0800
commit0a49a4ce600f74bfd982df19ab3cf9892c056759 (patch)
tree0a65947ee4e0e09fc3cd1edb9f6836d50896835b /editors/pdfedit
parentd756e586ddbc2f1c0202ffc0abbceecbb9b9294e (diff)
downloadfreebsd-ports-gnome-0a49a4ce600f74bfd982df19ab3cf9892c056759.tar.gz
freebsd-ports-gnome-0a49a4ce600f74bfd982df19ab3cf9892c056759.tar.zst
freebsd-ports-gnome-0a49a4ce600f74bfd982df19ab3cf9892c056759.zip
- Update to version 0.4.5
PR: 158458 Submitted by: Ports Fury
Diffstat (limited to 'editors/pdfedit')
-rw-r--r--editors/pdfedit/Makefile38
-rw-r--r--editors/pdfedit/distinfo4
-rw-r--r--editors/pdfedit/files/patch-Makefile.flags.in18
-rw-r--r--editors/pdfedit/files/patch-configure14
-rw-r--r--editors/pdfedit/files/patch-doc__Makefile12
-rw-r--r--editors/pdfedit/files/patch-src-kernel-cpdf.cc29
-rw-r--r--editors/pdfedit/files/patch-src__gui__base.cc24
-rw-r--r--editors/pdfedit/files/patch-src__gui__pdfutil.cc24
-rw-r--r--editors/pdfedit/files/patch-src__kernel__cpagecontents.cc34
-rw-r--r--editors/pdfedit/files/patch-src__qsa__configure11
-rw-r--r--editors/pdfedit/files/patch-src__tools__pdf_to_text.cc17
-rw-r--r--editors/pdfedit/pkg-descr2
-rw-r--r--editors/pdfedit/pkg-plist85
13 files changed, 152 insertions, 160 deletions
diff --git a/editors/pdfedit/Makefile b/editors/pdfedit/Makefile
index bd8061801a1c..2813cafb5bd4 100644
--- a/editors/pdfedit/Makefile
+++ b/editors/pdfedit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pdfedit
-PORTVERSION= 0.4.1
-PORTREVISION= 5
+PORTVERSION= 0.4.5
CATEGORIES= editors
MASTER_SITES= SF
@@ -18,19 +17,40 @@ BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
t1.5:${PORTSDIR}/devel/t1lib
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/doc/LICENSE.GPL
+
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
USE_QT_VER= 3
+USE_PERL5_BUILD=yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++"
-MAKE_ENV= ${CONFIGURE_ENV} QTDIR="${LOCALBASE}"
-CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++"
+CONFIGURE_ARGS= --with-t1-library=${LOCALBASE}/lib \
+ --with-t1-includes=${LOCALBASE}/include \
+ --with-parallel-make=off
+MAKE_ENV= ${CONFIGURE_ENV}
+MAKE_JOBS_SAFE= yes
MAN1= pdfedit.1
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-pedantic||g ; \
+ s| $$(OPTIM)||g ; \
+ s| $$(ARCH)||g ; \
+ s| -pipe.*$$||g ; \
+ s|^CFLAGS =|CFLAGS +=|g ; \
+ s|^CXXFLAGS =|CXXFLAGS +=|g' ${WRKSRC}/Makefile.flags.in
+ @${REINPLACE_CMD} -e \
+ '/QMAKE/s| make| $$MAKE|g' ${WRKSRC}/src/qsa/configure
+
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gui/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in Changelog README doc/AUTHORS
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/editors/pdfedit/distinfo b/editors/pdfedit/distinfo
index 9c7941112da0..13f3a323c202 100644
--- a/editors/pdfedit/distinfo
+++ b/editors/pdfedit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pdfedit-0.4.1.tar.bz2) = e12c3cb0e12775d296983212f69d66381de0eee6b94cc9a7dc10c1196b719522
-SIZE (pdfedit-0.4.1.tar.bz2) = 2958137
+SHA256 (pdfedit-0.4.5.tar.bz2) = 33ad8d59f4e51d8befd2dc2c577516e16c0cd11ebd3d22fed38233a793c6a4b9
+SIZE (pdfedit-0.4.5.tar.bz2) = 3026130
diff --git a/editors/pdfedit/files/patch-Makefile.flags.in b/editors/pdfedit/files/patch-Makefile.flags.in
deleted file mode 100644
index 4bb4dbfb8fcd..000000000000
--- a/editors/pdfedit/files/patch-Makefile.flags.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./Makefile.flags.in.orig 2008-02-20 14:45:18.000000000 -0300
-+++ ./Makefile.flags.in 2008-03-10 13:32:13.000000000 -0300
-@@ -107,11 +107,11 @@
- EXTRA_GUI_CXXFLAGS = -D CONFIG_DATA_PATH="$(DATA_PATH)"
-
- # same like for compiler stuff we also define 2 levels
--CONFIG_CFLAGS = $(DEBUG) $(OPTIM) $(ARCH) $(WARN) $(C_EXTRA) -pipe
--CONFIG_CXXFLAGS = $(DEBUG) $(OPTIM) $(ARCH) $(WARN) $(CXX_EXTRA) $(OBSERVER_CXXFLAGS) -pipe
-+CONFIG_CFLAGS = $(DEBUG) $(OPTIM) $(WARN) $(C_EXTRA) -pipe
-+CONFIG_CXXFLAGS = $(DEBUG) $(OPTIM) $(WARN) $(CXX_EXTRA) $(OBSERVER_CXXFLAGS) -pipe
-
--CFLAGS = $(CONFIG_CFLAGS)
--CXXFLAGS = $(CONFIG_CXXFLAGS)
-+CFLAGS += $(CONFIG_CFLAGS)
-+CXXFLAGS += $(CONFIG_CXXFLAGS)
-
- #######################################
- # Absolute paths for all components
diff --git a/editors/pdfedit/files/patch-configure b/editors/pdfedit/files/patch-configure
deleted file mode 100644
index b54e0a1c561d..000000000000
--- a/editors/pdfedit/files/patch-configure
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./configure.orig 2008-02-24 15:59:23.000000000 -0300
-+++ ./configure 2008-03-10 13:27:12.000000000 -0300
-@@ -5141,11 +5141,6 @@
- done
-
- fi
-- if test "x$link_iostreams" != "xyes"; then
-- { { echo "$as_me:$LINENO: error: Could not link against $ax_lib !" >&5
--echo "$as_me: error: Could not link against $ax_lib !" >&2;}
-- { (exit 1); exit 1; }; }
-- fi
- fi
-
- CPPFLAGS="$CPPFLAGS_SAVED"
diff --git a/editors/pdfedit/files/patch-doc__Makefile b/editors/pdfedit/files/patch-doc__Makefile
new file mode 100644
index 000000000000..915269137241
--- /dev/null
+++ b/editors/pdfedit/files/patch-doc__Makefile
@@ -0,0 +1,12 @@
+--- doc/Makefile.orig 2008-12-03 09:16:03.000000000 +0900
++++ doc/Makefile 2011-03-21 20:34:48.000000000 +0900
+@@ -18,9 +18,6 @@
+ $(USER_MANUAL_INSTALL_TARGET) \
+ $(DOXYGEN_INSTALL_TARGET) \
+ $(ADVANCED_DOC_INSTALL_TARGET)
+- $(MKDIR) $(INSTALL_ROOT)$(DOC_PATH)/;
+- $(COPY_FILE) LICENSE.GPL ../README ../Changelog AUTHORS README-* \
+- README.cygwin $(INSTALL_ROOT)$(DOC_PATH)
+
+ # TODO maybe we should be less brutal here and delete only our files However we
+ # have no list of installed doc files. This list is probably too much effort
diff --git a/editors/pdfedit/files/patch-src-kernel-cpdf.cc b/editors/pdfedit/files/patch-src-kernel-cpdf.cc
deleted file mode 100644
index e1229d55d18b..000000000000
--- a/editors/pdfedit/files/patch-src-kernel-cpdf.cc
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/kernel/cpdf.cc.orig 2008-02-22 11:42:07.000000000 +0300
-+++ src/kernel/cpdf.cc 2009-02-28 05:38:20.000000000 +0300
-@@ -2347,7 +2347,7 @@
- instance->file = file;
- kernelPrintDbg(debug::DBG_INFO, "Instance created successfully openMode=" << openMode);
- return instance;
-- }catch(exception &e)
-+ }catch(std::exception &e)
- {
- kernelPrintDbg(DBG_CRIT, "Pdf instance creation failed. cause="<<e.what());
- string what=string("CPdf open failed. reason=")+e.what();
-@@ -2631,7 +2631,7 @@
- try
- {
- minPos = getNodePosition(*this, newValue, &nodeCountCache);
-- }catch(exception &e)
-+ }catch(std::exception &e)
- {
- // position can't be determined
- // no special handling is needed, minPos keeps its value
-@@ -2690,7 +2690,7 @@
- kernelPrintDbg(DBG_WARN, "page with original position="<<i->first<<" is ambiguous. Invalidating.");
- // page position is ambiguous and so it has to be invalidate
- i->second->invalidate();
-- }catch(exception & e)
-+ }catch(std::exception & e)
- {
- kernelPrintDbg(DBG_CRIT, "Unexpected error. cause="<<e.what());
- assert(!"Possibly bug.");
diff --git a/editors/pdfedit/files/patch-src__gui__base.cc b/editors/pdfedit/files/patch-src__gui__base.cc
new file mode 100644
index 000000000000..491b562bf508
--- /dev/null
+++ b/editors/pdfedit/files/patch-src__gui__base.cc
@@ -0,0 +1,24 @@
+--- src/gui/base.cc.orig 2010-02-22 10:17:40.000000000 +0900
++++ src/gui/base.cc 2011-03-21 20:36:57.000000000 +0900
+@@ -688,7 +688,20 @@
+ if (openMode=="readonly") mode=CPdf::ReadOnly;
+ if (openMode=="readwrite") mode=CPdf::ReadWrite;
+ //Basic mode without asking a password (we do not know how)
+- return CPdf::getInstance(util::convertFromUnicode(filename,util::NAME).c_str(),mode);
++ boost::shared_ptr<pdfobjects::CPdf> pdf;
++ do {
++ try {
++ pdf = CPdf::getInstance(util::convertFromUnicode(filename,util::NAME).c_str(),mode);
++ }catch(PdfOpenException &e) {
++ // try to fallback to readonly mode
++ if (mode >= CPdf::ReadWrite) {
++ mode = CPdf::ReadOnly;
++ continue;
++ }
++ throw e;
++ }
++ }while(!pdf);
++ return pdf;
+ }
+
+ /** \copydoc loadFromFile */
diff --git a/editors/pdfedit/files/patch-src__gui__pdfutil.cc b/editors/pdfedit/files/patch-src__gui__pdfutil.cc
new file mode 100644
index 000000000000..21830bf30e08
--- /dev/null
+++ b/editors/pdfedit/files/patch-src__gui__pdfutil.cc
@@ -0,0 +1,24 @@
+--- src/gui/pdfutil.cc.orig 2009-04-07 00:24:47.000000000 +0900
++++ src/gui/pdfutil.cc 2011-03-21 20:36:57.000000000 +0900
+@@ -451,7 +451,20 @@
+ @param askPassword If true, password will be asked for if necessary
+ */
+ boost::shared_ptr<CPdf> getPdfInstance(QWidget *parent, const QString &filename, CPdf::OpenMode mode, bool askPassword) {
+- boost::shared_ptr<CPdf> pdf=CPdf::getInstance(util::convertFromUnicode(filename,util::NAME).c_str(), mode);
++ boost::shared_ptr<pdfobjects::CPdf> pdf;
++ do {
++ try {
++ pdf = CPdf::getInstance(util::convertFromUnicode(filename,util::NAME).c_str(),mode);
++ }catch(PdfOpenException &e) {
++ // try to fallback to readonly mode
++ if (mode >= CPdf::ReadWrite) {
++ mode = CPdf::ReadOnly;
++ continue;
++ }
++ throw e;
++ }
++ }while(!pdf);
++
+ if (askPassword && pdf->needsCredentials()) {
+ for(;;) {
+ //Ask for password until we either get the right one or user gets bored with retrying
diff --git a/editors/pdfedit/files/patch-src__kernel__cpagecontents.cc b/editors/pdfedit/files/patch-src__kernel__cpagecontents.cc
new file mode 100644
index 000000000000..c035213c2f31
--- /dev/null
+++ b/editors/pdfedit/files/patch-src__kernel__cpagecontents.cc
@@ -0,0 +1,34 @@
+--- src/kernel/cpagecontents.cc.orig 2010-04-30 21:44:30.000000000 +0900
++++ src/kernel/cpagecontents.cc 2011-03-21 20:39:56.000000000 +0900
+@@ -379,6 +379,12 @@
+
+ // Get the text
+ libs::Rectangle rec = (rc)? *rc : _page->display()->getPageRect();
++ // if we use rotation 90,270 then we must change the rectangle from which we want the text
++ // accordingly (TODO - verify for all rotations)
++ int rot = _page->getRotation ();
++ if (90 == rot || 270 == rot)
++ std::swap (rec.xright, rec.yright);
++
+ scoped_ptr<GString> gtxt (textDev->getText(rec.xleft, rec.yleft, rec.xright, rec.yright));
+ text = gtxt->getCString();
+ }
+@@ -540,10 +546,14 @@
+
+
+ CDict image_dict;
+- image_dict.addProperty ("W", CInt (image_size.x));
+- image_dict.addProperty ("H", CInt (image_size.y));
+- image_dict.addProperty ("CS", CName ("RGB"));
+- image_dict.addProperty ("BPC", CInt (8));
++ CInt x (image_size.x);
++ image_dict.addProperty ("W", x);
++ CInt y (image_size.y);
++ image_dict.addProperty ("H", y);
++ CName n ("RGB");
++ image_dict.addProperty ("CS", n);
++ CInt i (8);
++ image_dict.addProperty ("BPC", i);
+ CInlineImage img (image_dict, what);
+ shared_ptr<CInlineImage> inline_image (new CInlineImage (image_dict, what));
+ shared_ptr<InlineImageCompositePdfOperator> BI(new InlineImageCompositePdfOperator (inline_image));
diff --git a/editors/pdfedit/files/patch-src__qsa__configure b/editors/pdfedit/files/patch-src__qsa__configure
deleted file mode 100644
index abf1e2751cd7..000000000000
--- a/editors/pdfedit/files/patch-src__qsa__configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/qsa/configure.orig 2008-01-16 10:50:31.000000000 -0300
-+++ ./src/qsa/configure 2008-03-10 13:36:40.000000000 -0300
-@@ -15,7 +15,7 @@
- # invoke 2nd stage
- echo Building second stage2 configure
- cd configure2
--$QMAKE && make > /dev/null
-+$QMAKE && $MAKE > /dev/null
- if [ $? -gt 0 -o ! -x configure2 ];
- then
- echo Failed to build
diff --git a/editors/pdfedit/files/patch-src__tools__pdf_to_text.cc b/editors/pdfedit/files/patch-src__tools__pdf_to_text.cc
new file mode 100644
index 000000000000..2336682491b1
--- /dev/null
+++ b/editors/pdfedit/files/patch-src__tools__pdf_to_text.cc
@@ -0,0 +1,17 @@
+--- src/tools/pdf_to_text.cc.orig 2010-04-23 15:58:36.000000000 +0900
++++ src/tools/pdf_to_text.cc 2011-03-21 20:37:12.000000000 +0900
+@@ -47,6 +47,14 @@
+ struct _textify {
+ string operator () (shared_ptr<CPage> page)
+ {
++ // Update display params to use media box not default page rect (DEFAULT_PAGE_RX, DEFAULT_PAGE_RY)
++ // TODO upsidedown? get/set
++ DisplayParams dp;
++ dp.useMediaBox = gTrue;
++ dp.crop = gFalse;
++ dp.rotate = page->getRotation ();
++ page->setDisplayParams (dp);
++
+ string text;
+ static const std::string encoding="UTF-8";
+ page->getText (text, &encoding);
diff --git a/editors/pdfedit/pkg-descr b/editors/pdfedit/pkg-descr
index 8425933f0361..a64a6ad63718 100644
--- a/editors/pdfedit/pkg-descr
+++ b/editors/pdfedit/pkg-descr
@@ -7,4 +7,4 @@ scripted, it is possible to create own scripts or plugins.
Target platform are operating systems of Unix type (Linux, BSD, ...), we are
using C++, XPDF, QT3 and QSA.
-WWW: http://pdfedit.petricek.net/
+WWW: http://pdfedit.cz/
diff --git a/editors/pdfedit/pkg-plist b/editors/pdfedit/pkg-plist
index 2b4a540c51b3..75affd8373a7 100644
--- a/editors/pdfedit/pkg-plist
+++ b/editors/pdfedit/pkg-plist
@@ -1,78 +1,12 @@
bin/pdfedit
-%%DOCSDIR%%/AUTHORS
-%%DOCSDIR%%/Changelog
-%%DOCSDIR%%/LICENSE.GPL
-%%DOCSDIR%%/README
-%%DOCSDIR%%/README-Tango
-%%DOCSDIR%%/README.cygwin
-%%DOCSDIR%%/gui/images/command_options_cmdedit.png
-%%DOCSDIR%%/gui/images/options_commandline.png
-%%DOCSDIR%%/gui/images/options_editor.png
-%%DOCSDIR%%/gui/images/options_execute.png
-%%DOCSDIR%%/gui/images/options_lookandfeel.png
-%%DOCSDIR%%/gui/images/options_objecttree.png
-%%DOCSDIR%%/gui/images/options_paths.png
-%%DOCSDIR%%/gui/images/options_toolbars.png
-%%DOCSDIR%%/gui/images/pagespace.png
-%%DOCSDIR%%/gui/images/pdfedit.png
-%%DOCSDIR%%/gui/images/propedit_all.png
-%%DOCSDIR%%/gui/images/propedit_catalog.png
-%%DOCSDIR%%/gui/images/propedit_edit.png
-%%DOCSDIR%%/gui/images/propedit_edit_add.png
-%%DOCSDIR%%/gui/images/propedit_edit_del.png
-%%DOCSDIR%%/gui/images/propedit_edit_ref.png
-%%DOCSDIR%%/gui/images/propedit_gfx_selection.png
-%%DOCSDIR%%/gui/images/propedit_impor.png
-%%DOCSDIR%%/gui/images/propedit_multiselection.png
-%%DOCSDIR%%/gui/images/propedit_op_desc.png
-%%DOCSDIR%%/gui/images/propedit_op_modes.png
-%%DOCSDIR%%/gui/images/propedit_opt_editor.png
-%%DOCSDIR%%/gui/images/propedit_opt_objtree.png
-%%DOCSDIR%%/gui/images/propedit_outlines.png
-%%DOCSDIR%%/gui/images/propedit_pages.png
-%%DOCSDIR%%/gui/images/propedit_rclick.png
-%%DOCSDIR%%/gui/images/propedit_stream.png
-%%DOCSDIR%%/gui/images/propedit_text_selection.png
-%%DOCSDIR%%/gui/images/theme1.png
-%%DOCSDIR%%/gui/images/theme2.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/dialog_addFont.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/dialog_dashpattern.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/dialog_editPageMetrics.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/dialog_extractedText.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/dialog_findText.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/insert_pages.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/menu_edit.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/menu_file.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/menu_help.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/menu_page.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/menu_tools.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/menu_view.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_draw.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_dynamic.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_main.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_operator.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_page.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_revision.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_selectionmode.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_text.png
-%%DOCSDIR%%/gui/menuAndToolbarsFun/images/toolbars_treeview.png
-%%DOCSDIR%%/images/filedialog.png
-%%DOCSDIR%%/images/inputitem.png
-%%DOCSDIR%%/images/inputtext.png
-%%DOCSDIR%%/images/messageb1.png
-%%DOCSDIR%%/images/pdfedit.png
-%%DOCSDIR%%/images/qchkbox-w.png
-%%DOCSDIR%%/images/qcombo1-w.png
-%%DOCSDIR%%/images/qgrpbox-w.png
-%%DOCSDIR%%/images/qlined-w.png
-%%DOCSDIR%%/images/qradiobt-w.png
-%%DOCSDIR%%/images/qsdateed.png
-%%DOCSDIR%%/images/qspinbox-w.png
-%%DOCSDIR%%/images/qstimeed.png
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/README
%%DATADIR%%/callback.qs
%%DATADIR%%/delinearize.qs
%%DATADIR%%/dialog_lib.qs
%%DATADIR%%/dialogs.qs
+%%DATADIR%%/flatten.qs
%%DATADIR%%/help/cs/index.html
%%DATADIR%%/help/cs/keyboard.html
%%DATADIR%%/help/images/filedialog.png
@@ -165,6 +99,7 @@ bin/pdfedit
%%DATADIR%%/icon/draw_rect.png
%%DATADIR%%/icon/expand.png
%%DATADIR%%/icon/first.png
+%%DATADIR%%/icon/flatten.png
%%DATADIR%%/icon/help.png
%%DATADIR%%/icon/hicolor/about.png
%%DATADIR%%/icon/hicolor/add_text.png
@@ -290,8 +225,10 @@ bin/pdfedit
%%DATADIR%%/lang/pdfedit_cs.qm
%%DATADIR%%/lang/pdfedit_de.qm
%%DATADIR%%/lang/pdfedit_es.qm
+%%DATADIR%%/lang/pdfedit_fr.qm
%%DATADIR%%/lang/pdfedit_ru.qm
%%DATADIR%%/lang/pdfedit_sk.qm
+%%DATADIR%%/lang/pdfedit_zh_TW.qm
%%DATADIR%%/menu.qs
%%DATADIR%%/mode.conf
%%DATADIR%%/operator.hint
@@ -299,6 +236,7 @@ bin/pdfedit
%%DATADIR%%/pdfeditrc
%%DATADIR%%/pdfoperator.qs
%%DATADIR%%/scripts/delinearize.qs
+%%DATADIR%%/scripts/flatten.qs
%%DATADIR%%/scripts/pdftoxml.qs
%%DATADIR%%/scripts/update.qs
%%DATADIR%%/test.qs
@@ -311,9 +249,4 @@ bin/pdfedit
@dirrm %%DATADIR%%/help/cs
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%/images
-@dirrm %%DOCSDIR%%/gui/menuAndToolbarsFun/images
-@dirrm %%DOCSDIR%%/gui/menuAndToolbarsFun
-@dirrm %%DOCSDIR%%/gui/images
-@dirrm %%DOCSDIR%%/gui
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%