aboutsummaryrefslogtreecommitdiffstats
path: root/editors/pico-alpine
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2007-12-21 18:40:25 +0800
committerdougb <dougb@FreeBSD.org>2007-12-21 18:40:25 +0800
commitd83f97ab9347889fd593ca9ddf0de1c1fb03598d (patch)
tree1c877df648c3b6ea8c2fcf81fb791686c1e2822b /editors/pico-alpine
parent3096e7c6cf79ea8822fd05290ac923b933772603 (diff)
downloadfreebsd-ports-gnome-d83f97ab9347889fd593ca9ddf0de1c1fb03598d.tar.gz
freebsd-ports-gnome-d83f97ab9347889fd593ca9ddf0de1c1fb03598d.tar.zst
freebsd-ports-gnome-d83f97ab9347889fd593ca9ddf0de1c1fb03598d.zip
Add a slave port for the Alpine version of pico.
Pico and Pilot are simple, display-oriented tools. Commands are displayed at the bottom of the screen, and context-sensitive help is provided. In Pico as characters are typed they are immediately inserted into the text. It has three basic features: paragraph justification, searching, and block cut/paste. In Pilot several basic file manipulation commands are provided: Delete, Rename, Copy, View, Launch, and Edit. The "View" and "Edit" commands operate on text files only. The "Edit" command invokes "pico." The "Launch" command provides a convenient way to either execute the selected file or to run an application on it. WWW: http://www.washington.edu/alpine/
Diffstat (limited to 'editors/pico-alpine')
-rw-r--r--editors/pico-alpine/Makefile36
-rw-r--r--editors/pico-alpine/pkg-descr17
-rw-r--r--editors/pico-alpine/pkg-plist2
3 files changed, 55 insertions, 0 deletions
diff --git a/editors/pico-alpine/Makefile b/editors/pico-alpine/Makefile
new file mode 100644
index 000000000000..df2c8bf029f2
--- /dev/null
+++ b/editors/pico-alpine/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pico-alpine
+# Date created: December 21, 2007
+# Whom: Doug Barton <dougb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pico-alpine
+PORTREVISION= 0
+CATEGORIES= editors
+DISTNAME= alpine-${PORTVERSION}
+
+COMMENT= [Al]PIne's message COmposition editor and Pilot file manager
+
+MASTERDIR= ${.CURDIR}/../../mail/alpine
+
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+PATCHDIR= # To void equivalent in master port
+PKGMESSAGE= /nonexistent # To void equivalent in master port
+
+PICO_ALPINE_SLAVE= yes
+
+MAN1= pico.1 pilot.1
+
+post-patch:
+ @${CP} ${WRKSRC}/imap/Makefile ${WRKSRC}/imap/Makefile.presed
+ @${SED} -e "s#^\(all:.*\) bundled\$$#\1#" \
+ ${WRKSRC}/imap/Makefile.presed > ${WRKSRC}/imap/Makefile
+ @${CP} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.presed
+ @${SED} -e "s#^\(SUBDIRS.*pico\).*#\1#" \
+ -e "s#^man_MANS.*#man_MANS = doc/pico.1 doc/pilot.1#" \
+ ${WRKSRC}/Makefile.in.presed > ${WRKSRC}/Makefile.in
+
+.include "${MASTERDIR}/Makefile"
diff --git a/editors/pico-alpine/pkg-descr b/editors/pico-alpine/pkg-descr
new file mode 100644
index 000000000000..c8a5b9a6d127
--- /dev/null
+++ b/editors/pico-alpine/pkg-descr
@@ -0,0 +1,17 @@
+Pico and Pilot are simple, display-oriented tools. Commands are displayed
+at the bottom of the screen, and context-sensitive help is provided.
+
+In Pico as characters are typed they are immediately inserted into the text.
+It has three basic features: paragraph justification, searching, and block
+cut/paste.
+
+In Pilot several basic file manipulation commands are provided:
+Delete, Rename, Copy, View, Launch, and Edit. The "View" and "Edit"
+commands operate on text files only. The "Edit" command invokes "pico."
+The "Launch" command provides a convenient way to either execute the selected
+file or to run an application on it.
+
+WWW: http://www.washington.edu/alpine/
+
+- Doug Barton
+dougb@FreeBSD.org
diff --git a/editors/pico-alpine/pkg-plist b/editors/pico-alpine/pkg-plist
new file mode 100644
index 000000000000..46fee040c4d7
--- /dev/null
+++ b/editors/pico-alpine/pkg-plist
@@ -0,0 +1,2 @@
+bin/pico
+bin/pilot