aboutsummaryrefslogtreecommitdiffstats
path: root/editors/psgml
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>2000-07-12 23:57:14 +0800
committershige <shige@FreeBSD.org>2000-07-12 23:57:14 +0800
commit5a719b3bcbe3ae29d6c78c41231d46a3edaba3a5 (patch)
treefcecc78d953c0b28d9ea6b7ad9d51bc51e52b083 /editors/psgml
parent093488a6c73e5f74e21f5338668735f844909b4b (diff)
downloadfreebsd-ports-gnome-5a719b3bcbe3ae29d6c78c41231d46a3edaba3a5.tar.gz
freebsd-ports-gnome-5a719b3bcbe3ae29d6c78c41231d46a3edaba3a5.tar.zst
freebsd-ports-gnome-5a719b3bcbe3ae29d6c78c41231d46a3edaba3a5.zip
Convert into EMACS_PORT_NAME style port.
Submitted by: OKAZAKI Tetsurou <okazaki@be.to>
Diffstat (limited to 'editors/psgml')
-rw-r--r--editors/psgml/Makefile49
1 files changed, 17 insertions, 32 deletions
diff --git a/editors/psgml/Makefile b/editors/psgml/Makefile
index 153acc823fea..957b12e08ce2 100644
--- a/editors/psgml/Makefile
+++ b/editors/psgml/Makefile
@@ -5,58 +5,43 @@
# $FreeBSD$
#
-PORTNAME= psgml-${EMACS_PORT}
+PORTNAME= psgml
PORTVERSION= ${PSGML_VER}
CATEGORIES= editors elisp
MASTER_SITES= ftp://ftp.lysator.liu.se/pub/sgml/
-DISTNAME= psgml-${PSGML_VER}
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER?= shige@FreeBSD.org
# distfile version
PSGML_VER= 1.2.1
PSGML_STARTUPEL= psgml-startup.el
-CATALOG= ${PREFIX}/share/sgml/catalog
+CATALOG= ${LOCALBASE}/share/sgml/catalog
+
+SCRIPTS_ENV= TARGETS="${PSGML_STARTUPEL}"
+PLIST_SUB= PSGML_STARTUPEL=${PSGML_STARTUPEL}
# This is a master port.
PORTCLASS?= master
.if (${PORTCLASS} == "master")
-EMACS_NAME= emacs
-EMACS_PORT= emacs
-EMACS_VER= 19.34
-EMACS_LIBDIR= share/${EMACS_NAME}
+EMACS_PORT_NAME= emacs
.endif
-# if RUN_DEPENDS emacs port name has the suffix `-common'
-.if !defined(HAS_COMMON_PORT)
-HAS_COMMON_PORT= NO
-.endif
+.include <bsd.port.pre.mk>
#
# emacs ports setup
#
-.if defined(EMACS_PORT)
-EMACS_CMD?= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
-BUILD_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
-.if defined(HAS_COMMON_PORT) && (${HAS_COMMON_PORT} == "YES")
-RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
-.else
-RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
-.endif
+.if defined(EMACS_PORT_NAME)
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --lispdir=${PREFIX}/${EMACS_LIBDIR}/site-lisp/psgml \
- --infodir=${PREFIX}/info
+CONFIGURE_ARGS= --lispdir=${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/psgml \
+ --infodir=${LOCALBASE}/info
CONFIGURE_ENV= EMACS=${EMACS_CMD}
-MAKE_FLAGS= EMACS=${EMACS_CMD}
-SCRIPTS_ENV= TARGETS="${PSGML_STARTUPEL}" \
- EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER}
-PLIST_SUB= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
- PSGML_STARTUPEL=${PSGML_STARTUPEL}
.else
.BEGIN:
@${ECHO} "Error: Bad port."
- @${ECHO} "You must define EMACS_NAME, EMACS_PORT, EMACS_VER, EMACS_LIBDIR."
+ @${ECHO} "You must define EMACS_PORT_NAME."
@${FALSE}
.endif
@@ -68,9 +53,9 @@ RUN_DEPENDS+= ${CATALOG}:${PORTSDIR}/textproc/dtd-catalogs
pre-configure:
(cd ${WRKSRC} ; \
for i in psgml.el psgml.texi ; do \
- ${RM} -f $${i}.in ; \
- ${MV} $${i} $${i}.in ; \
- ${CAT} $${i}.in | ${SED} -e "s;@prefix@;${PREFIX};g" > $${i} ; \
+ ${RM} -f $${i}.in; \
+ ${MV} $${i} $${i}.in; \
+ ${CAT} $${i}.in | ${SED} -e "s;@prefix@;${LOCALBASE};g" > $${i}; \
done)
${CP} ${FILESDIR}/${PSGML_STARTUPEL}.in ${WRKDIR}
@@ -79,6 +64,6 @@ post-install:
${MAKE} install-info ; \
)
@${INSTALL_DATA} ${WRKDIR}/${PSGML_STARTUPEL} \
- ${PREFIX}/${EMACS_LIBDIR}/site-lisp
+ ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>