aboutsummaryrefslogtreecommitdiffstats
path: root/editors/staroffice52
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-08-25 21:48:08 +0800
committerjedgar <jedgar@FreeBSD.org>2000-08-25 21:48:08 +0800
commitd54ca814786af0268974f11a6382800440714093 (patch)
treed2452b8fbf8aadbe10f2f36f7fc90178fcf326ca /editors/staroffice52
parente8cc3d24cb5c4732774697d768c9cfe0defe2068 (diff)
downloadfreebsd-ports-gnome-d54ca814786af0268974f11a6382800440714093.tar.gz
freebsd-ports-gnome-d54ca814786af0268974f11a6382800440714093.tar.zst
freebsd-ports-gnome-d54ca814786af0268974f11a6382800440714093.zip
- Add DISPLAY functionality to keep StarOffice from crashing during
installation and startup - Make a few cosmetic fixes to the Makefile(s) Submitted by: Martin Blapp <mb@imp.ch> (Maintainer)
Diffstat (limited to 'editors/staroffice52')
-rw-r--r--editors/staroffice52/Makefile44
-rw-r--r--editors/staroffice52/files/setup.patch12
-rw-r--r--editors/staroffice52/files/soffice.patch12
3 files changed, 49 insertions, 19 deletions
diff --git a/editors/staroffice52/Makefile b/editors/staroffice52/Makefile
index 1bc196999aa6..415da7fe386b 100644
--- a/editors/staroffice52/Makefile
+++ b/editors/staroffice52/Makefile
@@ -23,24 +23,42 @@ NO_BUILD= yes
DIST_SUBDIR= staroffice52
WRKSRC= ${WRKDIR}/office52
TMPDIR= ${WRKDIR}/tmp
+ADEBAS= soa-5_2-ga-bin-linux-en.bin
.include <bsd.port.pre.mk>
-#
-# Staroffice depends on a scripting fix for
-# src/sys/i386/linux/linux_sysvec. It should
-# be revision 1.55.2.1 or higher. Please upgrade
-# to FreeBSD 4.1
-#
+pre-fetch:
.if ${OSVERSION} < 410000
-BROKEN= YES
+ @${ECHO}
+ @${ECHO} OS-VERSION ${OSVERSION}
+ @${ECHO}
+ @${ECHO} Staroffice depends on a scripting fix for
+ @${ECHO} src/sys/i386/linux/linux_sysvec. It should
+ @${ECHO} be revision 1.55.2.1 or higher.
+ @${ECHO}
+ @${ECHO} Please upgrade to FreeBSD 4.1
+ @${ECHO}
+ @${FALSE}
.endif
-
.if defined(WITH_CDROM)
-IGNORE= "Please mount the Sun StarOffice 5.2 CDROM onto /cdrom and run make again."
-.else # FTP/web download
+ @${ECHO}
+ @${ECHO} Please mount the Sun StarOffice 5.2 CDROM
+ @${ECHO} onto /cdrom and run make again.
+ @${ECHO}
+ @${FALSE}
+.else
.if !exists(${_DISTDIR}/${DISTNAME})
-IGNORE="Please manually download ${DISTNAME} from http://www.sun.com/staroffice. Put ${DISTNAME} into the directory ${_DISTDIR} and run make again. Or, if you have the Sun StarOffice 5.2 CDROM, please run 'make USE_CDROM=yes'"
+ @${ECHO} Please manually download ${DISTFILES}
+ @${ECHO} from http://www.sun.com/staroffice.
+ @${ECHO}
+ @${ECHO} ${ADEBAS} is the database part of Staroffice.
+ @${ECHO}
+ @${ECHO} Put ${DISTFILES} into the directory
+ @${ECHO} ${_DISTDIR} and run make again.
+ @${ECHO} Or, if you have the Sun StarOffice 5.2 CDROM,
+ @${ECHO} please run 'make USE_CDROM=yes'
+ @${ECHO}
+ @${FALSE}
.endif
.endif
@@ -65,7 +83,7 @@ do-extract:
@${CHMOD} 755 ${WRKSRC}/${DISTNAME}
@${CHMOD} 755 ${WRKSRC}/soa-5_2-ga-bin-linux-en.bin
@cd ${WRKSRC}
- @${WRKSRC}/${DISTNAME} -extract ${WRKSRC}
+ @SAL_IGNOREXERRORS=1 ${WRKSRC}/${DISTNAME} -extract ${WRKSRC}
@cd ../../
.endif
@@ -84,7 +102,7 @@ do-install:
@${LN} -fs /compat/linux/usr/local/office52 ${PREFIX}/office52
.endif
@${CAT} ${PKGDIR}/MESSAGE
- @-TEMP=${TMPDIR} /compat/linux/bin/sh -c '${WRKSRC}/setup /net'
+ @-SAL_IGNOREXERRORS=1 TEMP=${TMPDIR} /compat/linux/bin/sh -c '${WRKSRC}/setup /net'
@ ${ECHO}
@ ${ECHO} Ignore the error-message. StarOffice5.2 has been installed
@ ${ECHO} successfully on your system.
diff --git a/editors/staroffice52/files/setup.patch b/editors/staroffice52/files/setup.patch
index 5f6b0b69a7e7..0316f6476df3 100644
--- a/editors/staroffice52/files/setup.patch
+++ b/editors/staroffice52/files/setup.patch
@@ -1,8 +1,14 @@
---- setup.orig Wed Aug 23 00:02:57 2000
-+++ setup Wed Aug 23 00:03:11 2000
-@@ -1,4 +1,4 @@
+--- setup.orig Mon May 8 08:20:00 2000
++++ setup.new Fri Aug 25 15:16:12 2000
+@@ -1,7 +1,10 @@
-#!/bin/sh
+#!/compat/linux/bin/sh
#
# StarOffice patch checking script
# (c) 2000, Sun Microsystems Inc.
++
++# fix coredump on remote DISPLAY (IRIX)
++export SAL_IGNOREXERRORS=1
+
+ # resolve installation directory
+ sd_platform=`uname -s`
diff --git a/editors/staroffice52/files/soffice.patch b/editors/staroffice52/files/soffice.patch
index 62dc300be297..f65b9ed73ffa 100644
--- a/editors/staroffice52/files/soffice.patch
+++ b/editors/staroffice52/files/soffice.patch
@@ -1,8 +1,14 @@
---- new Wed Aug 23 00:09:46 2000
-+++ soffice Tue Aug 22 23:58:14 2000
-@@ -1,4 +1,4 @@
+--- soffice Mon May 8 08:20:00 2000
++++ soffice.new Fri Aug 25 15:19:40 2000
+@@ -1,7 +1,10 @@
-#!/bin/sh
+#!/compat/linux/bin/sh
#
# StarOffice startup script
# (c) 1999 Sun Microsystems, Inc.
++
++# fix coredump on remote DISPLAY (IRIX)
++export SAL_IGNOREXERRORS=1
+
+ #
+ # STAR_PROFILE_LOCKING_DISABLED=1