aboutsummaryrefslogtreecommitdiffstats
path: root/editors/texmaker/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-07-18 21:52:01 +0800
committermakc <makc@FreeBSD.org>2012-07-18 21:52:01 +0800
commit28e42f2cb141057e50b2cb8fcfbdfd96f597a116 (patch)
treedd55cae29736dad70f041a18ecefc094cf077039 /editors/texmaker/Makefile
parent18670d56f92a5a20e4a86c9ad711dbbd82b551ee (diff)
downloadfreebsd-ports-gnome-28e42f2cb141057e50b2cb8fcfbdfd96f597a116.tar.gz
freebsd-ports-gnome-28e42f2cb141057e50b2cb8fcfbdfd96f597a116.tar.zst
freebsd-ports-gnome-28e42f2cb141057e50b2cb8fcfbdfd96f597a116.zip
Update to 3.4
Convert to new option framework Normalize Makefile header
Diffstat (limited to 'editors/texmaker/Makefile')
-rw-r--r--editors/texmaker/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 3c87389c6b9c..c97cf4ca58d5 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -1,14 +1,12 @@
-# ex:ts=8
# Ports collection makefile for: texmaker
-# Date created: Dec 29, 2003
-# Whom: ijliao
+# Date created: 2003-12-29
+# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= texmaker
-PORTVERSION= 3.3.3
-PORTREVISION= 1
+PORTVERSION= 3.4
PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
@@ -31,18 +29,19 @@ QMAKE_ARGS= PREFIX=${PREFIX} ICONDIR=${PREFIX}/share/pixmaps \
DESKTOPDIR=${DESKTOPDIR}
MAKE_JOBS_SAFE= yes
-OPTIONS= XDVI "view dvi with xdvi" Off \
- GV "view ps with gv" Off
+OPTIONS_DEFINE= GV XDVI
+GV_DESC= View ps files with gv
+XDVI_DESC= View dvi files with xdvi
STRIP_FILES= bin/texmaker
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_XDVI)
+.if ${PORT_OPTIONS:MXDVI}
RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
.endif
-.if !defined(WITHOUT_GV)
+.if ${PORT_OPTIONS:MGV}
RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
.endif