aboutsummaryrefslogtreecommitdiffstats
path: root/editors/texmaker/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-27 21:27:44 +0800
committerrafan <rafan@FreeBSD.org>2007-07-27 21:27:44 +0800
commit7376e72b29d4385a2c15a21e3f10f949dd14d196 (patch)
tree31a1ef2a1e7b0e2bb41e52f89919e5fa5d13ac65 /editors/texmaker/Makefile
parent97f8e323d1700d8db694711562b91b2b4b09942e (diff)
downloadfreebsd-ports-gnome-7376e72b29d4385a2c15a21e3f10f949dd14d196.tar.gz
freebsd-ports-gnome-7376e72b29d4385a2c15a21e3f10f949dd14d196.tar.zst
freebsd-ports-gnome-7376e72b29d4385a2c15a21e3f10f949dd14d196.zip
- Update to 1.6
- Use DATADIR - Make runtime dependency optional (default on) - Pass maintainership to submitter PR: ports/114339 Submitted by: Max Brazhnikov <makc at issp.ac.ru>
Diffstat (limited to 'editors/texmaker/Makefile')
-rw-r--r--editors/texmaker/Makefile31
1 files changed, 23 insertions, 8 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 9278ea97057f..b02ada04a677 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -7,30 +7,45 @@
#
PORTNAME= texmaker
-PORTVERSION= 1.5
-PORTREVISION= 1
+PORTVERSION= 1.6
PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= makc@issp.ac.ru
COMMENT= LaTeX Development Environment
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
dvips:${PORTSDIR}/print/dvipsk-tetex \
- xdvi:${PORTSDIR}/print/xdvik \
- gv:${PORTSDIR}/print/gv \
- xpdf:${PORTSDIR}/graphics/xpdf \
-${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+ ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_BZIP2= yes
USE_GHOSTSCRIPT=yes
USE_QT_VER= 4
QT_COMPONENTS= gui moc qmake rcc uic
HAS_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
+OPTIONS= XDVI "view dvi with xdvi" On \
+ GV "view ps with gv" On \
+ XPDF "view pdf with xpdf" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XDVI)
+RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
+.endif
+
+.if !defined(WITHOUT_GV)
+RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
+.endif
+
+.if !defined(WITHOUT_XPDF)
+RUN_DEPENDS+= xpdf:${PORTSDIR}/graphics/xpdf
+.endif
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} -unix PREFIX=${PREFIX} texmaker.pro
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>