aboutsummaryrefslogtreecommitdiffstats
path: root/editors/texmakerx
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-26 15:28:58 +0800
committerbapt <bapt@FreeBSD.org>2013-03-26 15:28:58 +0800
commitbdae0ad187ce4e2219d274fcab5d571b62e49214 (patch)
tree3f78079cadbc6b7162b6a1662001ae268289a2c7 /editors/texmakerx
parent70ea43467175b11dab0cfb64ec869915aa517ee1 (diff)
downloadfreebsd-ports-gnome-bdae0ad187ce4e2219d274fcab5d571b62e49214.tar.gz
freebsd-ports-gnome-bdae0ad187ce4e2219d274fcab5d571b62e49214.tar.zst
freebsd-ports-gnome-bdae0ad187ce4e2219d274fcab5d571b62e49214.zip
Finish converting the editor category to new options framework
Diffstat (limited to 'editors/texmakerx')
-rw-r--r--editors/texmakerx/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/editors/texmakerx/Makefile b/editors/texmakerx/Makefile
index 5753e52f55a3..a797c0434cd6 100644
--- a/editors/texmakerx/Makefile
+++ b/editors/texmakerx/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: texmakerx
-# Date created: Feb 22, 2009
-# Whom: lx
-#
+# Created by: lx
# $FreeBSD$
-#
PORTNAME= texmakerx
PORTVERSION= 2.1
@@ -30,16 +26,17 @@ HAS_CONFIGURE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
-OPTIONS= XDVI "view dvi with xdvi" On \
- GV "view ps with gv" On
+OPTIONS_DEFINE= XDVI GV
+GV_DESC= View ps files with gv
+XDVI_DESC= View dvi files with xdvi
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_XDVI)
+.if ${PORT_OPTIONS:MXDVI}
RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
.endif
-.if !defined(WITHOUT_GV)
+.if ${PORT_OPTIONS:MGV}
RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
.endif
@@ -53,4 +50,4 @@ do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} PREFIX=${PREFIX} ${PORTNAME}.pro
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>