aboutsummaryrefslogtreecommitdiffstats
path: root/editors/textroom
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
committermakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
commita24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e (patch)
tree9d348bd41c93dc07e16d63761a277862fca2beec /editors/textroom
parent59c0a46aa2540ee31e961d5f970ecb9f7804f01e (diff)
downloadfreebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.gz
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.zst
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.zip
- Convert unmaintained ports to USES=qmake
- Add stage support - Convert LIB_DEPENDS to new syntax - Minor changes/fixes
Diffstat (limited to 'editors/textroom')
-rw-r--r--editors/textroom/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/editors/textroom/Makefile b/editors/textroom/Makefile
index 3116864d6876..612f1ec0fa2f 100644
--- a/editors/textroom/Makefile
+++ b/editors/textroom/Makefile
@@ -14,22 +14,16 @@ LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26 \
libcurl.so:${PORTSDIR}/ftp/curl
-USES= shared-mime-info
+USES= qmake shared-mime-info
USE_SDL= mixer
USE_QT4= moc_build qmake_build rcc_build uic_build corelib gui xml \
svg opengl qt3support
-QMAKE_ARGS= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
-HAS_CONFIGURE= yes
+QMAKE_ARGS= LOCALBASE=${LOCALBASE}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
${WRKSRC}/application/src/textroom.cpp \
${WRKSRC}/application/src/getaword.cpp \
${WRKSRC}/application/src/optionsdialog.cpp
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS} textroom.pro
-
.include <bsd.port.mk>