aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2007-10-26 00:31:25 +0800
committerobrien <obrien@FreeBSD.org>2007-10-26 00:31:25 +0800
commit82df83e806be799368ecb31fedd704a1b3bbf8d8 (patch)
tree97e6934163ba1087a3a012720700c844e581b878 /editors/vim/Makefile
parent8ad3a86f9701aeda63f9ad7aee508c86f794d69e (diff)
downloadfreebsd-ports-gnome-82df83e806be799368ecb31fedd704a1b3bbf8d8.tar.gz
freebsd-ports-gnome-82df83e806be799368ecb31fedd704a1b3bbf8d8.tar.zst
freebsd-ports-gnome-82df83e806be799368ecb31fedd704a1b3bbf8d8.zip
Update to Vim 7.1 patchlevel 145.
Diffstat (limited to 'editors/vim/Makefile')
-rw-r--r--editors/vim/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 069c7f18285c..097607c4f982 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME?= vim
-PATCHLEVEL= 116
+PATCHLEVEL= 145
PORTVERSION= 7.1.${PATCHLEVEL}
RELEASE= vim-${PORTVERSION:C/\.[0-9a-z]*$//}
PORTREVISION?= 0
@@ -19,7 +19,7 @@ PATCH_SITES= ${MASTER_SITES:S|unix|patches/${PORTVERSION:C/\.[0-9a-z]*$//}|}
PATCHFILES!= /usr/bin/jot -s " " -w ${PORTVERSION:C/\.[0-9]*$//}.%03d \
${PATCHLEVEL} 1 ${PATCHLEVEL}
# bits to remove
-BADPATCHES= 003 007 041 065 070 072 080 088 091 092
+BADPATCHES= 003 007 041 065 070 072 080 088 091 092 124 126 128 129 134
.for p in ${BADPATCHES}
PATCHFILES:= ${PATCHFILES:N7.1.${p}}
.endfor
@@ -231,8 +231,9 @@ cklatest:
find-bad-patches:
cd ${DISTDIR} ; egrep -l \
- '(src/if_ole|src/gui_(w32|w48|mac)|src/os_(riscos|cyg|os2|vms|amiga|win32|mswin))'\
+ '(src/if_ole|src/gui_(w32|w48|mac)|src/os_(riscos|cyg|os2|vms|amiga|win32|mswin))|src/Make_(cyg|mvc)'\
vim/${PORTVERSION:C/\.[0-9a-z]*$//}*
+
vim-makesum:
${MAKE} WITH_LANG=yes makesum