aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2007-01-03 06:41:37 +0800
committerstas <stas@FreeBSD.org>2007-01-03 06:41:37 +0800
commit8e77422c036990568df5a1191475fce9ff4b4f54 (patch)
tree30e054016e491631f1ef64666c4842ac5a30dd8d /editors/vim/Makefile
parent84869d391384ec63a8934f131a58ebabccd3b6e4 (diff)
downloadfreebsd-ports-gnome-8e77422c036990568df5a1191475fce9ff4b4f54.tar.gz
freebsd-ports-gnome-8e77422c036990568df5a1191475fce9ff4b4f54.tar.zst
freebsd-ports-gnome-8e77422c036990568df5a1191475fce9ff4b4f54.zip
- FreeBSD's ctags has no -R option.
Approved by: maintainer timeout (4 months)
Diffstat (limited to 'editors/vim/Makefile')
-rw-r--r--editors/vim/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 1d0707792ce5..7bc0d0eaaf67 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -10,7 +10,7 @@ PORTNAME?= vim
PATCHLEVEL= 178
PORTVERSION= 7.0.${PATCHLEVEL}
RELEASE= vim-${PORTVERSION:C/\.[0-9a-z]*$//}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= editors
MASTER_SITES= ${MASTER_SITE_VIM}
DISTFILES= ${RELEASE}${EXTRACT_SUFX}
@@ -46,6 +46,7 @@ WRKSRC= ${WRKDIR}/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}/src
PATCH_DIST_ARGS= -d ${WRKSRC:S/src$//} --batch --forward --quiet -E ${PATCH_DIST_STRIP}
# consider
#PATCH_DIST_ARGS= -t
+REINPLACE_ARGS= -i ""
MAKE_ARGS+= CONF_ARGS="--prefix=${PREFIX} --with-tlib=termlib ${CSCOPE_ARG}"
ALL_TARGET= #
_DATADIR= ${RELEASE:S/-//g:S/.//g}
@@ -156,6 +157,11 @@ post-extract:
@${TAR} -C ${WRKDIR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${LANG_FILE}
.endif
+post-patch:
+ @(${FIND} ${WRKSRC}/../runtime/ -name menu\*.vim -print0 | ${XARGS} -0\
+ ${REINPLACE_CMD} \
+ -e 's,ctags -R \.,${FIND} . -type f|${XARGS} ctags,g')
+
pre-configure:
@(cd ${WRKSRC} ; ${MAKE} distclean)
@${REINPLACE_CMD} -e ' \