aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim6
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2001-02-15 20:18:48 +0800
committerobrien <obrien@FreeBSD.org>2001-02-15 20:18:48 +0800
commita905bcd5edf1ba71b815c68a00f083b9c2b6d163 (patch)
treedb907f376ba90ebbed6558b4f565432dd153a472 /editors/vim6
parent39954aa92a7b5133b631bd359865a2c54e8d392e (diff)
downloadfreebsd-ports-gnome-a905bcd5edf1ba71b815c68a00f083b9c2b6d163.tar.gz
freebsd-ports-gnome-a905bcd5edf1ba71b815c68a00f083b9c2b6d163.tar.zst
freebsd-ports-gnome-a905bcd5edf1ba71b815c68a00f083b9c2b6d163.zip
Remove multiple `multibyte' specifications. Also sync the vim6 up
with how this is done in the vim5 port. Submitted by: clive
Diffstat (limited to 'editors/vim6')
-rw-r--r--editors/vim6/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/editors/vim6/Makefile b/editors/vim6/Makefile
index 3483f05c4ce5..f3949e538d6a 100644
--- a/editors/vim6/Makefile
+++ b/editors/vim6/Makefile
@@ -49,17 +49,18 @@ MLINKS= vim.1 rvim.1 vim.1 rview.1
MLINKS+= vim.1 gvim.1 vim.1 gview.1 vim.1 rgvim.1 vim.1 rgview.1
MAKE_ARGS+= X_LIBS=-lxpg4 CONF_OPT_MAX="--enable-max-features"
+I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
.if defined(WITH_ATHENA)
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"
+MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena" ${I18N}
#MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=yes" ${I18N}
.elif defined(WITH_GTK)
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --enable-multibyte --enable-fontset --enable-xim"
+MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE}" ${I18N}
MAKE_ARGS+= CONF_OPT_PERL="--enable-pythoninterp"
MAKE_ARGS+= X_LIBS="$(X_LIBS) -lXt"
.else
USE_MOTIF= yes
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\" --enable-multibyte --enable-fontset --enable-multibyte --enable-xim" MOTIFHOME=${X11BASE}
+MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\"" MOTIFHOME=${X11BASE} ${I18N}
.endif
.if defined(PACKAGE_BUILDING)