aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2012-05-29 06:04:54 +0800
committeradamw <adamw@FreeBSD.org>2012-05-29 06:04:54 +0800
commitb91b0183c768166d04ec8195abd0a199f4a17f5f (patch)
tree6ed908cfc6cabcd19ae658eee77ecc23428fd002 /editors/vim
parent0be2972c4227ccd83fdef44952bfddec797b802d (diff)
downloadfreebsd-ports-gnome-b91b0183c768166d04ec8195abd0a199f4a17f5f.tar.gz
freebsd-ports-gnome-b91b0183c768166d04ec8195abd0a199f4a17f5f.tar.zst
freebsd-ports-gnome-b91b0183c768166d04ec8195abd0a199f4a17f5f.zip
Fix gnome2 support. Two bugs prevented the GNOME2 config options from
being acknowledged. [1] A check was made for WITH_GNOME, instead of WITH_GNOME2 [2] A check explicitly ignored the WITH_GNOME2 option unless that variable was set to "1" or "yes", despite bsd.options.mk specifically setting it to "true" PR: ports/164129 Approved by: maintainer timeout (4.5 months)
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 32538a2e3c59..7bad77ea04a9 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -136,7 +136,7 @@ MAKE_ARGS+= CONF_OPT_TCL="--enable-tclinterp --with-tclsh="${TCLSH:S/${LOCALBASE
. if !defined(WITHOUT_X11)
# for now default the GUI to the GTK+ one
-. if !defined(WITH_X11_ONLY) && !defined(WITH_ATHENA) && !defined(WITH_MOTIF) && !defined(WITH_GNOME) && !defined(WITH_GTK2)
+. if !defined(WITH_X11_ONLY) && !defined(WITH_ATHENA) && !defined(WITH_MOTIF) && !defined(WITH_GNOME2) && !defined(WITH_GTK2)
WITH_GTK2= yes
. endif
@@ -148,14 +148,11 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk2 --with-gtk-prefix=${LOCALBASE}" ${I1
MAKE_ARGS+= X_LIBS="$(X_LIBS) -lXt"
USE_XORG+= xt
. elif defined(WITH_GNOME2)
-. if ${WITH_GNOME2:Mlibgnomeui}!="" || ${WITH_GNOME2}=="yes" || \
- ${WITH_GNOME2}=="1"
USE_GNOME= libgnomeui
PKGNAMESUFFIX= -gnome2
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gnome2" ${I18N}
MAKE_ARGS+= X_LIBS="$(X_LIBS) -lXt"
USE_XORG+= xt
-. endif
. elif defined(WITH_MOTIF)
USE_MOTIF= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\"" MOTIFHOME=${LOCALBASE} ${I18N}