aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:47:41 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:47:41 +0800
commit4495def283d3b8c777e1eb5b958cedb25b1aa16b (patch)
treed7741a9f974e1e8c5428027e641c709984c997cf /editors/vim
parent72ce7050d03c812e37966786e11996a90713afea (diff)
downloadfreebsd-ports-gnome-4495def283d3b8c777e1eb5b958cedb25b1aa16b.tar.gz
freebsd-ports-gnome-4495def283d3b8c777e1eb5b958cedb25b1aa16b.tar.zst
freebsd-ports-gnome-4495def283d3b8c777e1eb5b958cedb25b1aa16b.zip
Implment WANT_GTK.
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile10
-rw-r--r--editors/vim/files/patch-024
2 files changed, 7 insertions, 7 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 82efea7c2629..95199b42cff7 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -45,15 +45,15 @@ PLIST_SUB= VIM_VER=${DISTNAME:S/-//:S/.//}
MAN1= vim.1 vimtutor.1 xxd.1 ectags.1
MLINKS= vim.1 rvim.1 vim.1 rview.1 ectags.1 etags.1
+.include <bsd.port.pre.mk>
+
.if !defined(LITE)
MLINKS+= vim.1 gvim.1 vim.1 gview.1 vim.1 rgvim.1 vim.1 rgview.1
MAKE_ARGS+= X_LIBS=-lxpg4 CONF_OPT_MAX="--enable-max-features"
-.if defined(HAVE_GTK)
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+.if defined(WITH_GTK)
+USE_GTK= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE} --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"
.elif defined(HAVE_MOTIF)
REQUIRES_MOTIF= yes
@@ -83,4 +83,4 @@ post-install:
@${RM} -f ${PREFIX}/man/man1/etags.1
@${MV} ${PREFIX}/man/man1/ctags.1 ${PREFIX}/man/man1/ectags.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/vim/files/patch-02 b/editors/vim/files/patch-02
index 06b3acdaf84f..c66db00b417c 100644
--- a/editors/vim/files/patch-02
+++ b/editors/vim/files/patch-02
@@ -5,12 +5,12 @@
if test "x$gtk_config_prefix" != "x" ; then
gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config
++ GTK_CONFIG=${GTK_CONFIG}
fi
if test "x$gtk_config_exec_prefix" != "x" ; then
gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config
++ GTK_CONFIG=${GTK_CONFIG}
fi
if test "X$GTK_CONFIG" = "X"; then
# Extract the first word of "gtk-config", so it can be a program name with args.