aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-04-07 00:11:48 +0800
committerobrien <obrien@FreeBSD.org>2003-04-07 00:11:48 +0800
commitaf2a0d0ddba85814ee9c53a4376529cbf88b7dc9 (patch)
tree27ca6f2a94bbbdc7e701c5d4d79d94482091fc18 /editors/vim
parent024d883d64320434be7b020eecfe6706dc85e605 (diff)
downloadfreebsd-ports-gnome-af2a0d0ddba85814ee9c53a4376529cbf88b7dc9.tar.gz
freebsd-ports-gnome-af2a0d0ddba85814ee9c53a4376529cbf88b7dc9.tar.zst
freebsd-ports-gnome-af2a0d0ddba85814ee9c53a4376529cbf88b7dc9.zip
Fix the DATADIR path in the cases where the distfile contains a patch level.
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 71ba3e75aa31..df322e7500ba 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -47,7 +47,7 @@ PATCH_DIST_ARGS= -d ${WRKSRC:S/src$//} --forward --quiet -E ${PATCH_DIST_STRIP}
MAKE_ARGS+= CONF_ARGS="--prefix=${PREFIX} --with-tlib=termlib ${CSCOPE_ARG}"
ALL_TARGET= #
PLIST_SUB= VIM_VER=${DISTNAME:S/-//:S/.//}
-DATADIR= ${PREFIX}/share/vim/${DISTNAME:S/-//:S/.//}
+DATADIR= ${PREFIX}/share/vim/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}
MAN1= evim.1 vim.1 vimdiff.1 vimtutor.1 xxd.1
MLINKS= vim.1 rvim.1 vim.1 rview.1
.if !defined(LITE)
@@ -154,11 +154,11 @@ post-install:
|| (cd ${PREFIX}/bin ; ${LN} -sf vim gvimdiff)
${INSTALL_DATA} ${FILESDIR}/vietnamese_viscii.vim ${DATADIR}/keymap
cd ${PREFIX} ;\
- ${FIND} share/vim/${DISTNAME:S/-//:S/.//}/ -type f -o -type l \
+ ${FIND} ${DATADIR:S/^${PREFIX}\///} -type f -o -type l \
| sort \
>${WRKDIR}/PLIST.share-vim
cd ${PREFIX} ;\
- ${FIND} share/vim/${DISTNAME:S/-//:S/.//}/ -type d \
+ ${FIND} ${DATADIR:S/^${PREFIX}\///} -type d \
| sort -r | ${SED} -e 's/^/@dirrm /g' \
>>${WRKDIR}/PLIST.share-vim
${ECHO_CMD} "r ${TMPPLIST}" > ${WRKDIR}/ex.script