aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2001-02-15 20:12:43 +0800
committerobrien <obrien@FreeBSD.org>2001-02-15 20:12:43 +0800
commit39954aa92a7b5133b631bd359865a2c54e8d392e (patch)
tree89538c976932f4ec95a97bffabacd80179e93f74 /editors/vim
parentae5670675976f4b01f8049f9a62540ed50f61c05 (diff)
downloadfreebsd-ports-gnome-39954aa92a7b5133b631bd359865a2c54e8d392e.tar.gz
freebsd-ports-gnome-39954aa92a7b5133b631bd359865a2c54e8d392e.tar.zst
freebsd-ports-gnome-39954aa92a7b5133b631bd359865a2c54e8d392e.zip
I shouldn't have been removing `gvim' from the non-GUI PLIST.
Also make the gvim link relative rather than absolute, in case someone specifies a different prefix when installing the package. Note there are some burned in paths in the vim binary, but there is no reason to totally make this not work, when it could somewhat.
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 77e0d1fd9374..3483f05c4ce5 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -67,18 +67,14 @@ MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp --enable-pythoninterp --enable-tc
.endif
.else # LITE
-PLIST= ${WRKDIR}/PLIST.nogui
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x"
MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable-tclinterp"
.endif # LITE
pre-build:
@(cd ${WRKSRC}; ${MAKE} distclean)
- @${SED} -e '/gvi/d' ${PKGDIR}/pkg-plist > ${WRKDIR}/PLIST.nogui
post-install:
-.if !defined(LITE)
- [ -e ${PREFIX}/bin/gvim ] || ${LN} -s ${PREFIX}/bin/vim ${PREFIX}/bin/gvim
-.endif
+ [ -e ${PREFIX}/bin/gvim ] || (cd ${PREFIX}/bin ; ${LN} -s vim gvim)
.include <bsd.port.post.mk>