aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-devel/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
committerrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
commitb028b113ef13fa7972bb45d681d7a0abe47c40a6 (patch)
treea76a27ca09341f754b493c264ee71c912a553d89 /editors/xemacs-devel/Makefile
parent855b1df39bc3a6f03abf878d9c99b5ba0838ba35 (diff)
downloadfreebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.gz
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.zst
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Diffstat (limited to 'editors/xemacs-devel/Makefile')
-rw-r--r--editors/xemacs-devel/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index 249af927ffeb..c858c33564fc 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xemacs-devel
PORTVERSION= ${XEMACS_VER:S/-/./}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
@@ -60,6 +60,22 @@ CONFIGURE_ARGS?=--enable-clash-detection \
MAKE_ARGS= prefix=${PREFIX}
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
+INFO= xemacs-${XEMACS_VER}/beta \
+ xemacs-${XEMACS_VER}/cl \
+ xemacs-${XEMACS_VER}/custom \
+ xemacs-${XEMACS_VER}/emodules \
+ xemacs-${XEMACS_VER}/external-widget \
+ xemacs-${XEMACS_VER}/info \
+ xemacs-${XEMACS_VER}/internals \
+ xemacs-${XEMACS_VER}/lispref \
+ xemacs-${XEMACS_VER}/new-users-guide \
+ xemacs-${XEMACS_VER}/standards \
+ xemacs-${XEMACS_VER}/term \
+ xemacs-${XEMACS_VER}/termcap \
+ xemacs-${XEMACS_VER}/texinfo \
+ xemacs-${XEMACS_VER}/widget \
+ xemacs-${XEMACS_VER}/xemacs-faq \
+ xemacs-${XEMACS_VER}/xemacs
ALL_TARGET= all dist
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}