aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-devel/Makefile
diff options
context:
space:
mode:
authorgj <gj@FreeBSD.org>1998-10-02 03:29:50 +0800
committergj <gj@FreeBSD.org>1998-10-02 03:29:50 +0800
commitc1622f72430f17ed527bf7f3ccf094de5f0a93e1 (patch)
tree8db532ebffb201151a98ed975036d47772048ca0 /editors/xemacs-devel/Makefile
parent91c7822ff631cbd4261950758c52cd4d69323701 (diff)
downloadfreebsd-ports-gnome-c1622f72430f17ed527bf7f3ccf094de5f0a93e1.tar.gz
freebsd-ports-gnome-c1622f72430f17ed527bf7f3ccf094de5f0a93e1.tar.zst
freebsd-ports-gnome-c1622f72430f17ed527bf7f3ccf094de5f0a93e1.zip
Do not use libDnd if we are package building (this is the --with-offix option).
Diffstat (limited to 'editors/xemacs-devel/Makefile')
-rw-r--r--editors/xemacs-devel/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index aead39d9fb67..bd6dff646396 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -3,7 +3,7 @@
# Date created: 26 August 1997
# Whom: Michael Elbel (me)
#
-# $Id: Makefile,v 1.20 1998/09/17 00:32:31 asami Exp $
+# $Id: Makefile,v 1.21 1998/09/17 00:50:47 asami Exp $
#
DISTNAME= xemacs-20.4
@@ -31,7 +31,7 @@ CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} \
--site-includes=${PREFIX}/include \
--site-libraries=${PREFIX}/lib \
--sitelispdir="${PREFIX}/lib/xemacs/site-lisp ${PREFIX}/share/emacs/site-lisp" \
- ${WITH_XFACE} ${WITH_MULE} ${WITH_DIALOGS}
+ ${WITH_XFACE} ${WITH_MULE} ${WITH_DIALOGS} ${WITH_OFFIX}
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
ALL_TARGET= all dist
@@ -58,9 +58,11 @@ PLIST= ${PKGDIR}/PLIST.mule
WITH_DIALOGS= --with-dialogs=athena
.endif
-# Drop faces if building package, autodetect otherwise
+# Drop faces (libcompface) and offix (libDnd) if building package,
+# autodetect otherwise
.if defined(PACKAGE_BUILDING)
WITH_XFACE?= --with-xface=no
+WITH_OFFIX?= --with-offix=no
.endif
post-install: