aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-packages
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-07-08 03:14:46 +0800
committeranray <anray@FreeBSD.org>2006-07-08 03:14:46 +0800
commit8fac096351829c66dff0d9da117f754b77ac27ab (patch)
treedec22200f9c8521c8fb487940c792216e1f6b18a /editors/xemacs-packages
parent82988e758a94561c965cb55a5ca7885e7f12aa93 (diff)
downloadfreebsd-ports-gnome-8fac096351829c66dff0d9da117f754b77ac27ab.tar.gz
freebsd-ports-gnome-8fac096351829c66dff0d9da117f754b77ac27ab.tar.zst
freebsd-ports-gnome-8fac096351829c66dff0d9da117f754b77ac27ab.zip
Change `default-process-coding-system' to `coding-system-for-read/write'
in gnus package for fix compatiblity with current xemacsen.
Diffstat (limited to 'editors/xemacs-packages')
-rw-r--r--editors/xemacs-packages/Makefile4
-rw-r--r--editors/xemacs-packages/files/patch-gnus.el35
2 files changed, 39 insertions, 0 deletions
diff --git a/editors/xemacs-packages/Makefile b/editors/xemacs-packages/Makefile
index c0cf77c5216a..5aec9ee6590e 100644
--- a/editors/xemacs-packages/Makefile
+++ b/editors/xemacs-packages/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xemacs-packages
PORTVERSION= 14.1
+PORTREVISION= 1
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= packages
@@ -135,6 +136,8 @@ WRKSRC= ${WRKDIR}/${PACKAGES_SUBDIR}
XEMACSDIR= ${PREFIX}/lib/xemacs
PACKAGES_SUBDIR= xemacs-packages
+FIXME= gnus/binhex.elc gnus/uudecode.elc
+
do-extract:
@${MKDIR} ${WRKSRC}
.for f in ${DISTFILES}
@@ -143,6 +146,7 @@ do-extract:
.endfor
post-patch:
+ cd ${WRKSRC}/lisp; ${RM} ${FIXME}
${FIND} ${WRKSRC} -name \*.orig -exec ${RM} -f \{} \;
do-install:
diff --git a/editors/xemacs-packages/files/patch-gnus.el b/editors/xemacs-packages/files/patch-gnus.el
new file mode 100644
index 000000000000..38a194f475c2
--- /dev/null
+++ b/editors/xemacs-packages/files/patch-gnus.el
@@ -0,0 +1,35 @@
+Index: lisp/uudecode.el
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/packages/xemacs-packages/gnus/lisp/uudecode.el,v
+retrieving revision 1.5
+diff -u -r1.5 uudecode.el
+--- lisp/gnus/uudecode.el 2006/03/16 04:18:08 1.5
++++ lisp/gnus/uudecode.el 2006/07/07 09:31:58
+@@ -100,7 +100,8 @@
+ (make-temp-name "uu")
+ uudecode-temporary-file-directory))))
+ (let ((cdir default-directory)
+- default-process-coding-system)
++ (coding-system-for-read 'binary)
++ (coding-system-for-write 'binary))
+ (unwind-protect
+ (with-temp-buffer
+ (insert "begin 600 " (file-name-nondirectory tempfile) "\n")
+Index: lisp/binhex.el
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/packages/xemacs-packages/gnus/lisp/binhex.el,v
+retrieving revision 1.5
+diff -u -r1.5 binhex.el
+--- lisp/gnus/binhex.el 2006/03/16 04:17:41 1.5
++++ lisp/gnus/binhex.el 2006/07/07 09:32:00
+@@ -289,7 +289,9 @@
+ (save-excursion
+ (goto-char start)
+ (when (re-search-forward binhex-begin-line nil t)
+- (let ((cdir default-directory) default-process-coding-system)
++ (let ((cdir default-directory)
++ (coding-system-for-read 'binary)
++ (coding-system-for-write 'binary))
+ (unwind-protect
+ (progn
+ (set-buffer (setq work-buffer