aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-packages
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 18:34:23 +0800
committerknu <knu@FreeBSD.org>2002-01-29 18:34:23 +0800
commitfdab120e8f7f5dc349cb1887034af51fe4834d3c (patch)
tree5ad72b52c789f91d654888bd06c860a242d912d6 /editors/xemacs-packages
parent683084ba5b0a2fbaac959371c452814420e77ba6 (diff)
downloadfreebsd-ports-gnome-fdab120e8f7f5dc349cb1887034af51fe4834d3c.tar.gz
freebsd-ports-gnome-fdab120e8f7f5dc349cb1887034af51fe4834d3c.tar.zst
freebsd-ports-gnome-fdab120e8f7f5dc349cb1887034af51fe4834d3c.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Diffstat (limited to 'editors/xemacs-packages')
-rw-r--r--editors/xemacs-packages/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/editors/xemacs-packages/Makefile b/editors/xemacs-packages/Makefile
index 5ab46d22da43..ab2f82ab15ae 100644
--- a/editors/xemacs-packages/Makefile
+++ b/editors/xemacs-packages/Makefile
@@ -121,11 +121,11 @@ do-install:
post-install:
@cd ${WRKDIR} && \
- find ${PACKAGES_SUBDIR} -type f|sort|${SED} 's:^:lib/xemacs/:' >> ${TMPPLIST}; \
- find ${PACKAGES_SUBDIR}/*/* -type d|sort -r|${SED} 's:^:@dirrm lib/xemacs/:'>> ${TMPPLIST}
- @${ECHO} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/* 2>/dev/null || true' >> ${TMPPLIST}
- @${ECHO} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR} 2>/dev/null || true' >> ${TMPPLIST}
- @${ECHO} '@unexec rmdir %D/lib/xemacs 2>/dev/null || true' >> ${TMPPLIST}
+ ${FIND} ${PACKAGES_SUBDIR} -type f|sort|${SED} 's:^:lib/xemacs/:' >> ${TMPPLIST}; \
+ ${FIND} ${PACKAGES_SUBDIR}/*/* -type d|sort -r|${SED} 's:^:@dirrm lib/xemacs/:'>> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/* 2>/dev/null || true' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR} 2>/dev/null || true' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs 2>/dev/null || true' >> ${TMPPLIST}
@${ECHO_MSG} " This is the set of the packages for xemacs with the xemacs-packages"
@${ECHO_MSG} "category. You might be enough only with this package(or if you are non-Latin"
@${ECHO_MSG} "people, together with xemacs-mule-packages) for working at XEmacs but if you"