aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs21-mule/Makefile
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>1999-12-08 20:39:56 +0800
committertaoka <taoka@FreeBSD.org>1999-12-08 20:39:56 +0800
commita90ceaaea75ce921cd77c71d3bc02943c1f929ff (patch)
treefbf4032642150a10ab2d0e680fb4cd1bd954efca /editors/xemacs21-mule/Makefile
parente8477e83a2c5a1c5311f92c91e27f2dbb3734e8c (diff)
downloadfreebsd-ports-gnome-a90ceaaea75ce921cd77c71d3bc02943c1f929ff.tar.gz
freebsd-ports-gnome-a90ceaaea75ce921cd77c71d3bc02943c1f929ff.tar.zst
freebsd-ports-gnome-a90ceaaea75ce921cd77c71d3bc02943c1f929ff.zip
Revived COMMENT, DESCR in these ports and then modified about it.
PR: 15331 Submitted by: maintainer
Diffstat (limited to 'editors/xemacs21-mule/Makefile')
-rw-r--r--editors/xemacs21-mule/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index b226981feebd..d094aef89b11 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -82,7 +82,6 @@ INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
STRIP=
INSTALL_TARGET?=install-arch-dep
-DESCR?= ${WRKDIR}/DESCR
PLIST?= ${PKGLDIR}/PLIST
PLIST_SUB?= XEMACS_DIR=${XEMACS_DIR} ARCH_SUBDIR=${ARCH_SUBDIR} EMACS_CMD=${EMACS_CMD}
@@ -102,10 +101,6 @@ WITH_INPUT_METHOD?= --with-canna=no --with-wnn=no --with-wnn6=no
.endif
.if !defined(MULE_COMMON)
-post-configure::
- @${SED} -e "s/%%XEMACS_VER%%/${XEMACS_VER}/g" \
- ${DESCR_TMPL} > ${DESCR}
-
pre-build:
@find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
@${RM} -f ${WRKSRC}/lib-src/DOC* ${WRKSRC}/src/xemacs
@@ -126,4 +121,10 @@ post-install::
post-package:
@${TOUCH} ${TOUCH_FLAGS} ${PACKAGE_COOKIE}
+# for make DESCR (only maintainer use)
+arrange::
+ @${MKDIR} ${PKGDIR}
+ @${SED} -e "s/%%XEMACS_VER%%/${XEMACS_VER}/g" \
+ ${DESCR_TMPL} > ${DESCR}
+
.include <bsd.port.mk>