aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs21-mule/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
committerrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
commitb028b113ef13fa7972bb45d681d7a0abe47c40a6 (patch)
treea76a27ca09341f754b493c264ee71c912a553d89 /editors/xemacs21-mule/Makefile
parent855b1df39bc3a6f03abf878d9c99b5ba0838ba35 (diff)
downloadfreebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.gz
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.zst
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Diffstat (limited to 'editors/xemacs21-mule/Makefile')
-rw-r--r--editors/xemacs21-mule/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index 9032a9fad45d..70929fb4c6c6 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -75,6 +75,7 @@ CONFIGURE_ARGS= --with-x11 \
${WITH_XIM} \
${WITH_MENUBARS} ${WITH_SCROLLBARS} \
${WITH_DIALOGS} ${WITH_WIDGETS}
+INFO_PATH= lib/xemacs-${XEMACS_VER}/info
MAKE_ARGS= prefix=${PREFIX}
ALL_TARGET= all dist
.if defined(PKGNAMEPREFIX)
@@ -188,6 +189,8 @@ pre-configure::
@${SED} -e 's/\.1/&.gz/' ${WRKSRC}/${f} > ${WRKDIR}/tmp_zot
@${MV} ${WRKDIR}/tmp_zot ${WRKSRC}/${f}
.endfor
+ @${REINPLACE_CMD} -e 's/^mandir=@mandir@/mandir=@mandir@\/man1/' \
+ ${WRKSRC}/Makefile.in.in
pre-build:
@${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) \