aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs21-mule
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-12-16 21:13:54 +0800
committeranray <anray@FreeBSD.org>2006-12-16 21:13:54 +0800
commit9e55b6273ece80ff610873b2323a786eaa6c5258 (patch)
treef005d8dfd34dd8202e38749e522b265732a584c0 /editors/xemacs21-mule
parenta4173d3b40c305a132c38c62c49426262341ea25 (diff)
downloadfreebsd-ports-gnome-9e55b6273ece80ff610873b2323a786eaa6c5258.tar.gz
freebsd-ports-gnome-9e55b6273ece80ff610873b2323a786eaa6c5258.tar.zst
freebsd-ports-gnome-9e55b6273ece80ff610873b2323a786eaa6c5258.zip
Fix build xemacs-mule with canna support.
Reported by: pointyhat via kris
Diffstat (limited to 'editors/xemacs21-mule')
-rw-r--r--editors/xemacs21-mule/Makefile6
-rw-r--r--editors/xemacs21-mule/pkg-plist1
2 files changed, 6 insertions, 1 deletions
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index 0b67a8b3061f..b5b92024f2bc 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xemacs-mule
PORTVERSION= ${XEMACS_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
@@ -153,11 +153,13 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/xcin2.5:${PORTSDIR}/chinese/xcin
CONFIGURE_ARGS+= --with-canna --with-wnn --with-wnn6=no
LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna \
wnn.0:${PORTSDIR}/japanese/FreeWnn-lib
+PLIST_SUB+= CANNA=""
.elif defined(CANNA) && defined(WNN6)
SITE_INCLUDES= ${LOCALBASE}/include/wnn6
CONFIGURE_ARGS+= --with-canna --with-wnn6
LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna \
wnn6.2:${PORTSDIR}/japanese/Wnn6-lib
+PLIST_SUB+= CANNA=""
.elif defined(FREEWNN)
CONFIGURE_ARGS+= --with-wnn --with-canna=no --with-wnn6=no
LIB_DEPENDS+= wnn.0:${PORTSDIR}/japanese/FreeWnn-lib
@@ -168,8 +170,10 @@ LIB_DEPENDS+= wnn6.2:${PORTSDIR}/japanese/Wnn6-lib
.elif defined(CANNA)
CONFIGURE_ARGS+= --with-canna --with-wnn=no --with-wnn6=no
LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna
+PLIST_SUB+= CANNA=""
.else
CONFIGURE_ARGS+= --with-canna=no --with-wnn=no --with-wnn6=no
+PLIST_SUB+= CANNA="@comment "
.endif
SITE_INCLUDES+= ${LOCALBASE}/include
SITE_LIBRARIES+= ${LOCALBASE}/lib
diff --git a/editors/xemacs21-mule/pkg-plist b/editors/xemacs21-mule/pkg-plist
index d8f41386f256..74e347741fbc 100644
--- a/editors/xemacs21-mule/pkg-plist
+++ b/editors/xemacs21-mule/pkg-plist
@@ -1098,6 +1098,7 @@ lib/xemacs-%%XEMACS_VER%%/lisp/mule/canna-leim.el
lib/xemacs-%%XEMACS_VER%%/lisp/mule/chinese.el
lib/xemacs-%%XEMACS_VER%%/lisp/mule/chinese.elc
lib/xemacs-%%XEMACS_VER%%/lisp/mule/custom-load.el
+%%CANNA%%lib/xemacs-%%XEMACS_VER%%/lisp/mule/custom-load.elc
lib/xemacs-%%XEMACS_VER%%/lisp/mule/cyrillic.el
lib/xemacs-%%XEMACS_VER%%/lisp/mule/cyrillic.elc
lib/xemacs-%%XEMACS_VER%%/lisp/mule/english.el