aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xmlcopyeditor
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-02-14 03:28:24 +0800
committerbeech <beech@FreeBSD.org>2009-02-14 03:28:24 +0800
commit11b8b30c0e90061ac159a0dcc4a2d58bddb6e1d6 (patch)
tree952bc01937db316a4d02ba4516d763f4f0cc9045 /editors/xmlcopyeditor
parent5ba890130810ec29dbbcb3f90970be9a0ae7a8b5 (diff)
downloadfreebsd-ports-gnome-11b8b30c0e90061ac159a0dcc4a2d58bddb6e1d6.tar.gz
freebsd-ports-gnome-11b8b30c0e90061ac159a0dcc4a2d58bddb6e1d6.tar.zst
freebsd-ports-gnome-11b8b30c0e90061ac159a0dcc4a2d58bddb6e1d6.zip
- Fix build problems
PR: ports/131574 Reported by: QAT Submitted by: Jose Garcia Juanino <jjuanino@gmail.com> Maintainer
Diffstat (limited to 'editors/xmlcopyeditor')
-rw-r--r--editors/xmlcopyeditor/Makefile1
-rw-r--r--editors/xmlcopyeditor/files/patch-src_wraplibxml.cpp.diff14
2 files changed, 15 insertions, 0 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index 8c50cf672624..2476cce30102 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmlcopyeditor
PORTVERSION= 1.2.0
+PORTREVISION= 1
DISTVERSIONSUFFIX=-2
CATEGORIES= editors
MASTER_SITES= SF
diff --git a/editors/xmlcopyeditor/files/patch-src_wraplibxml.cpp.diff b/editors/xmlcopyeditor/files/patch-src_wraplibxml.cpp.diff
new file mode 100644
index 000000000000..f0ce205c2dee
--- /dev/null
+++ b/editors/xmlcopyeditor/files/patch-src_wraplibxml.cpp.diff
@@ -0,0 +1,14 @@
+--- src/wraplibxml.cpp.orig
++++ src/wraplibxml.cpp
+@@ -20,6 +20,11 @@
+ #include "wraplibxml.h"
+ #include <sstream>
+ #include <stdexcept>
++
++#ifdef ATTRIBUTE_PRINTF
++#undef ATTRIBUTE_PRINTF
++#endif
++
+ #include <wx/wx.h>
+
+ WrapLibxml::WrapLibxml ( bool netAccessParameter, const std::string& catalogPathParameter )