aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xmleditor
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-14 17:10:15 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-14 17:10:15 +0800
commit7efac6a47c35147e84da099faa9a75793b15f509 (patch)
treeab9b971e260f4fb412d888c2de4b18620c317589 /editors/xmleditor
parent54d283ee86b95b0aef0fc36ace6bc25cbdf65cc9 (diff)
downloadfreebsd-ports-gnome-7efac6a47c35147e84da099faa9a75793b15f509.tar.gz
freebsd-ports-gnome-7efac6a47c35147e84da099faa9a75793b15f509.tar.zst
freebsd-ports-gnome-7efac6a47c35147e84da099faa9a75793b15f509.zip
Fix the build with GCC 4.2.
Reported by: pointyhat
Diffstat (limited to 'editors/xmleditor')
-rw-r--r--editors/xmleditor/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/editors/xmleditor/Makefile b/editors/xmleditor/Makefile
index a980f3ca10d0..e287c677dca4 100644
--- a/editors/xmleditor/Makefile
+++ b/editors/xmleditor/Makefile
@@ -28,4 +28,10 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
USE_LDCONFIG= yes
+# Fix for GCC 4.2
+post-patch:
+ @${REINPLACE_CMD} -e '257s,((char\*)\*n),n,' \
+ -e '/gtk_xml_modules_add_module/s,const ,,' \
+ ${WRKSRC}/src/gtkxmlmodules.*
+
.include <bsd.port.mk>