aboutsummaryrefslogtreecommitdiffstats
path: root/editors/zile
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2006-02-01 09:08:58 +0800
committerbarner <barner@FreeBSD.org>2006-02-01 09:08:58 +0800
commit3193bfc871096a963b0df82b59af8910eb00d293 (patch)
tree85ee40e09ee89a2aed6d4873f15f81cd6746a3b1 /editors/zile
parent5cc58d009ce95c965140497254172c1b9b918140 (diff)
downloadfreebsd-ports-gnome-3193bfc871096a963b0df82b59af8910eb00d293.tar.gz
freebsd-ports-gnome-3193bfc871096a963b0df82b59af8910eb00d293.tar.zst
freebsd-ports-gnome-3193bfc871096a963b0df82b59af8910eb00d293.zip
- Update to 2.2.11
Submitted by: Ports Fury PR: ports/92614
Diffstat (limited to 'editors/zile')
-rw-r--r--editors/zile/Makefile24
-rw-r--r--editors/zile/distinfo6
-rw-r--r--editors/zile/files/patch-configure11
3 files changed, 24 insertions, 17 deletions
diff --git a/editors/zile/Makefile b/editors/zile/Makefile
index 380a72695767..64830917a5d7 100644
--- a/editors/zile/Makefile
+++ b/editors/zile/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zile
-PORTVERSION= 2.2.9
+PORTVERSION= 2.2.11
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,9 +15,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Small emacs-like text editor
USE_GETOPT_LONG=yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-allegro --disable-epocemx
+CONFIGURE_ENV= LIBS="-lgnuregex"
+CONFIGURE_ARGS= --disable-allegro --disable-epocemx
MAN1= zile.1
INFO= zile
@@ -25,4 +27,20 @@ PLIST_FILES= bin/zile %%DATADIR%%/AUTODOC %%DATADIR%%/FAQ %%DATADIR%%/HELP \
%%DATADIR%%/TUTORIAL %%DATADIR%%/dotzile.sample
PLIST_DIRS= %%DATADIR%%
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 502010
+GNU_REGEX_H= gnu/regex.h
+.else
+GNU_REGEX_H= gnuregex.h
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|<regex\.h>|<${GNU_REGEX_H}>|g ; \
+ s|_regex_h|_${GNU_REGEX_H:S/\//_/g:S/./_/g}|g ; \
+ s|-pedantic||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|<regex\.h>|<${GNU_REGEX_H}>|g' ${WRKSRC}/src/search.c
+
+.include <bsd.port.post.mk>
diff --git a/editors/zile/distinfo b/editors/zile/distinfo
index 5c0ff14d5c4b..cc21b787d3ac 100644
--- a/editors/zile/distinfo
+++ b/editors/zile/distinfo
@@ -1,3 +1,3 @@
-MD5 (zile-2.2.9.tar.gz) = 8bf8d2a51b2f110771e8c80e16a25de2
-SHA256 (zile-2.2.9.tar.gz) = a839c128d3094d035c9d87a2ffbb46c933653bf2b01e09b717ec737c7b848193
-SIZE (zile-2.2.9.tar.gz) = 329533
+MD5 (zile-2.2.11.tar.gz) = 0f498e6d8b3d2262f8da913de9e40de5
+SHA256 (zile-2.2.11.tar.gz) = f1e84a3da2fc210e75a5ea9fda89147bd264b453b7248c243885b6a324543ea4
+SIZE (zile-2.2.11.tar.gz) = 329618
diff --git a/editors/zile/files/patch-configure b/editors/zile/files/patch-configure
deleted file mode 100644
index 1aab141ad572..000000000000
--- a/editors/zile/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Aug 8 08:08:03 2005
-+++ configure Sat Aug 20 22:50:30 2005
-@@ -3993,7 +3993,7 @@
-
-
- if test "$GCC" = "yes"; then
-- CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wstrict-prototypes -pedantic"
-+ CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wstrict-prototypes"
- fi
-
-