aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-06-08 19:58:16 +0800
committeritetcu <itetcu@FreeBSD.org>2009-06-08 19:58:16 +0800
commit06f68442e4f98f4aff9fd5af789da7d4e36d20cb (patch)
treeb270612ecb52234838d5ec2126cc357fc92bfc80 /editors
parent9a0cbb37a9db536cb85a59df00d107c61f97a650 (diff)
downloadfreebsd-ports-gnome-06f68442e4f98f4aff9fd5af789da7d4e36d20cb.tar.gz
freebsd-ports-gnome-06f68442e4f98f4aff9fd5af789da7d4e36d20cb.tar.zst
freebsd-ports-gnome-06f68442e4f98f4aff9fd5af789da7d4e36d20cb.zip
Fix build with custom PREFIX.
Submitted by: maintainer Reported by: QATty
Diffstat (limited to 'editors')
-rw-r--r--editors/yzis/Makefile2
-rw-r--r--editors/yzis/files/patch-cmake__modules__FindLibLua51.cmake18
2 files changed, 20 insertions, 0 deletions
diff --git a/editors/yzis/Makefile b/editors/yzis/Makefile
index 8c5e537671ff..d9a6ec456d38 100644
--- a/editors/yzis/Makefile
+++ b/editors/yzis/Makefile
@@ -29,6 +29,8 @@ USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
CMAKE_BUILD_TYPE= Release
CMAKE_ARGS+= -DLOCALBASE:STRING="${LOCALBASE}" \
+ -DLUA_INCDIR:STRING="${LUA_INCDIR}" \
+ -DLUA_LIBDIR:STRING="${LUA_LIBDIR}" \
-DENABLE_QYZIS:BOOL=ON \
-DENABLE_LIBYZISRUNNER:BOOL=OFF \
-DENABLE_TESTS:BOOL=OFF
diff --git a/editors/yzis/files/patch-cmake__modules__FindLibLua51.cmake b/editors/yzis/files/patch-cmake__modules__FindLibLua51.cmake
new file mode 100644
index 000000000000..c9e4ee7f0324
--- /dev/null
+++ b/editors/yzis/files/patch-cmake__modules__FindLibLua51.cmake
@@ -0,0 +1,18 @@
+--- ./cmake/modules/FindLibLua51.cmake.orig 2008-06-26 01:35:28.000000000 +0300
++++ ./cmake/modules/FindLibLua51.cmake 2009-06-08 14:29:41.309522776 +0300
+@@ -28,6 +28,7 @@
+ FIND_PACKAGE(GNUWIN32)
+
+ FIND_PATH(LIBLUA51_INCLUDE_DIR lua.h
++ ${LUA_INCDIR}
+ ${WITH_LUA_HOME}/include
+ ${_libLua51IncDir}/lua51
+ ${_libLua51IncDir}/lua5.1
+@@ -41,6 +42,7 @@
+
+ FIND_LIBRARY(LIBLUA51_LIBRARIES NAMES lua5.1 lua51 lua
+ PATHS
++ ${LUA_LIBDIR}
+ ${WITH_LUA_HOME}/lib
+ ${_libLua51LinkDir}
+ ${_libLuaLinkDir}