aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2001-09-05 06:30:19 +0800
committeralex <alex@FreeBSD.org>2001-09-05 06:30:19 +0800
commit47e6cf070d1b86fa7132e2579e92c612e4fb0d6f (patch)
treed7b66ab6366bd8b952bd19b4e14c7e2ca1a89e27 /editors
parent38bdd9c26a60465bbbe01372244d7b078d943613 (diff)
downloadfreebsd-ports-gnome-47e6cf070d1b86fa7132e2579e92c612e4fb0d6f.tar.gz
freebsd-ports-gnome-47e6cf070d1b86fa7132e2579e92c612e4fb0d6f.tar.zst
freebsd-ports-gnome-47e6cf070d1b86fa7132e2579e92c612e4fb0d6f.zip
- Add check for installed and running linprocfs
- Sync french version with the english and german version Submitted by: Martin Blapp <mb@imp.ch> (MAINTAINER)
Diffstat (limited to 'editors')
-rw-r--r--editors/staroffice52/Makefile16
-rw-r--r--editors/staroffice60/Makefile16
-rw-r--r--editors/staroffice70/Makefile16
3 files changed, 48 insertions, 0 deletions
diff --git a/editors/staroffice52/Makefile b/editors/staroffice52/Makefile
index 071cf24afa8f..abf03b7e2984 100644
--- a/editors/staroffice52/Makefile
+++ b/editors/staroffice52/Makefile
@@ -40,10 +40,26 @@ INSTDB.INS= ${PREFIX}/office52/program/instdb.ins
SUNSOLVE= ${WRKDIR}/109939-02
ADABAS_DIST= soa-5_2-ga-bin-linux-en.bin
SIZE!= /bin/df -k . | /usr/bin/tail -n 1 | /usr/bin/awk '{print $$4}'
+LINPROCFS!= mount | grep linprocfs | awk '{print $1}'
.include <bsd.port.pre.mk>
pre-fetch:
+.if ${LINPROCFS}
+ @${ECHO}
+ @${ECHO} Check if linprocfs is running: YES
+.else
+ @${ECHO} -----------------------------------------------------------
+ @${ECHO}
+ @${ECHO} Staroffice setup needs a running linprocfs, which is not
+ @${ECHO} activated on your system. Please read the linprocfs(5)
+ @${ECHO} manpage and add the following line to /etc/fstab:
+ @${ECHO}
+ @${ECHO} linproc /compat/linux/proc linprocfs rw 0 0
+ @${ECHO}
+ @${ECHO} -----------------------------------------------------------
+ @${FALSE}
+.endif
.if ${OSVERSION} < 410000
@${ECHO}
@${ECHO} OS-VERSION ${OSVERSION}
diff --git a/editors/staroffice60/Makefile b/editors/staroffice60/Makefile
index 071cf24afa8f..abf03b7e2984 100644
--- a/editors/staroffice60/Makefile
+++ b/editors/staroffice60/Makefile
@@ -40,10 +40,26 @@ INSTDB.INS= ${PREFIX}/office52/program/instdb.ins
SUNSOLVE= ${WRKDIR}/109939-02
ADABAS_DIST= soa-5_2-ga-bin-linux-en.bin
SIZE!= /bin/df -k . | /usr/bin/tail -n 1 | /usr/bin/awk '{print $$4}'
+LINPROCFS!= mount | grep linprocfs | awk '{print $1}'
.include <bsd.port.pre.mk>
pre-fetch:
+.if ${LINPROCFS}
+ @${ECHO}
+ @${ECHO} Check if linprocfs is running: YES
+.else
+ @${ECHO} -----------------------------------------------------------
+ @${ECHO}
+ @${ECHO} Staroffice setup needs a running linprocfs, which is not
+ @${ECHO} activated on your system. Please read the linprocfs(5)
+ @${ECHO} manpage and add the following line to /etc/fstab:
+ @${ECHO}
+ @${ECHO} linproc /compat/linux/proc linprocfs rw 0 0
+ @${ECHO}
+ @${ECHO} -----------------------------------------------------------
+ @${FALSE}
+.endif
.if ${OSVERSION} < 410000
@${ECHO}
@${ECHO} OS-VERSION ${OSVERSION}
diff --git a/editors/staroffice70/Makefile b/editors/staroffice70/Makefile
index 071cf24afa8f..abf03b7e2984 100644
--- a/editors/staroffice70/Makefile
+++ b/editors/staroffice70/Makefile
@@ -40,10 +40,26 @@ INSTDB.INS= ${PREFIX}/office52/program/instdb.ins
SUNSOLVE= ${WRKDIR}/109939-02
ADABAS_DIST= soa-5_2-ga-bin-linux-en.bin
SIZE!= /bin/df -k . | /usr/bin/tail -n 1 | /usr/bin/awk '{print $$4}'
+LINPROCFS!= mount | grep linprocfs | awk '{print $1}'
.include <bsd.port.pre.mk>
pre-fetch:
+.if ${LINPROCFS}
+ @${ECHO}
+ @${ECHO} Check if linprocfs is running: YES
+.else
+ @${ECHO} -----------------------------------------------------------
+ @${ECHO}
+ @${ECHO} Staroffice setup needs a running linprocfs, which is not
+ @${ECHO} activated on your system. Please read the linprocfs(5)
+ @${ECHO} manpage and add the following line to /etc/fstab:
+ @${ECHO}
+ @${ECHO} linproc /compat/linux/proc linprocfs rw 0 0
+ @${ECHO}
+ @${ECHO} -----------------------------------------------------------
+ @${FALSE}
+.endif
.if ${OSVERSION} < 410000
@${ECHO}
@${ECHO} OS-VERSION ${OSVERSION}