aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-03 20:13:23 +0800
committerbapt <bapt@FreeBSD.org>2013-09-03 20:13:23 +0800
commit74e0f8a8b686b5907c28d2392a09652cada4ca50 (patch)
tree969d85a11701cc0a743c50f26376c759b7da5a4d /editors
parentcfe05aaa850def1fcb987abccbb3e58403ad9257 (diff)
downloadfreebsd-ports-gnome-74e0f8a8b686b5907c28d2392a09652cada4ca50.tar.gz
freebsd-ports-gnome-74e0f8a8b686b5907c28d2392a09652cada4ca50.tar.zst
freebsd-ports-gnome-74e0f8a8b686b5907c28d2392a09652cada4ca50.zip
Add an explicit dependency on pkgconf
Diffstat (limited to 'editors')
-rw-r--r--editors/conglomerate/Makefile7
-rw-r--r--editors/gedit-plugins/Makefile3
-rw-r--r--editors/ghex/Makefile9
-rw-r--r--editors/gphpedit/Makefile8
-rw-r--r--editors/mlview/Makefile3
5 files changed, 8 insertions, 22 deletions
diff --git a/editors/conglomerate/Makefile b/editors/conglomerate/Makefile
index 0e6fa5db05b4..d192292f1bde 100644
--- a/editors/conglomerate/Makefile
+++ b/editors/conglomerate/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: conglomerate
-# Date created: Jun 26, 2003
-# Whom: Pav Lucistnik <pav@oook.cz>
-#
+# Created by: Pav Lucistnik <pav@oook.cz>
# $FreeBSD$
PORTNAME= conglomerate
@@ -14,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME2 visual XML editor with emphasis on DocBook editing
INSTALLS_OMF= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= libgnomeui gtksourceview gnomeprefix gnomehack intlhack
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 7109198d756c..8dc9eaf6a745 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -21,9 +21,8 @@ CONFLICTS= gedit-plugins-3.[0-9]*
USE_LDCONFIG= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix intlhack gnomevfs2
WANT_GNOME= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/editors/ghex/Makefile b/editors/ghex/Makefile
index b7691dd78ed7..c14627fff470 100644
--- a/editors/ghex/Makefile
+++ b/editors/ghex/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: ghex2
-# Date created: 15 September 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/editors/ghex/Makefile,v 1.13 2008/08/23 18:22:59 mezz Exp $
-#
PORTNAME= ghex
PORTVERSION= 2.24.0
@@ -17,10 +13,9 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2 hex editor
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui libgnomeui \
gnomedocutils
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
diff --git a/editors/gphpedit/Makefile b/editors/gphpedit/Makefile
index a572ad3fa0b0..1a1a614a612f 100644
--- a/editors/gphpedit/Makefile
+++ b/editors/gphpedit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gphpedit
-# Date created: 2004-11-21
-# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
-#
+# Created by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
# $FreeBSD$
-#
PORTNAME= gphpedit
PORTVERSION= 0.9.80
@@ -16,7 +12,7 @@ MASTER_SITES= http://www.gphpedit.org/download/store/ \
MAINTAINER= novel@FreeBSD.org
COMMENT= PHP, HTML, and CSS development environment for GNOME 2.x
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack libgnomeui libgtkhtml
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
index 387d8163e962..c65851638d22 100644
--- a/editors/mlview/Makefile
+++ b/editors/mlview/Makefile
@@ -13,9 +13,8 @@ COMMENT= A tree oriented XML editor for Gnome
USE_BZIP2= yes
USE_AUTOTOOLS= autoconf libtool
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= eel2 gnomeprefix gtksourceview libgnomeui
-USE_GMAKE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib `pkg-config --libs gnome-vfs-2.0 libgnomeui-2.0`"
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags gnome-vfs-2.0 libgnomeui-2.0`