aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-30 08:53:22 +0800
committeredwin <edwin@FreeBSD.org>2005-11-30 08:53:22 +0800
commit8295e3f9e36b2ea6019654e04d3355d7be4958a1 (patch)
treeedc71c1ab9f2aaa2d116e2cff3710776404becad /editors
parent0d17ba313e362280b38279e96be357c8573201b6 (diff)
downloadfreebsd-ports-gnome-8295e3f9e36b2ea6019654e04d3355d7be4958a1.tar.gz
freebsd-ports-gnome-8295e3f9e36b2ea6019654e04d3355d7be4958a1.tar.zst
freebsd-ports-gnome-8295e3f9e36b2ea6019654e04d3355d7be4958a1.zip
[MAINTAINER] editors/rospell: fix build on 4.x
4.x make doesn't know what BSDmakefile is so tekk it what to use. Remove HAS_CONFIGURE= yes because we don't use distributed ./configure At the end, it still failed on 4.x. A short discussion with the submitter ended up in a "let's keep it broken on 4.x" PR: ports/89740 Submitted by: Ion-Mihai Tetcu <itetcu@people.tecnik93.com>
Diffstat (limited to 'editors')
-rw-r--r--editors/rospell/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/rospell/Makefile b/editors/rospell/Makefile
index c48050fff736..75b93bdf85d7 100644
--- a/editors/rospell/Makefile
+++ b/editors/rospell/Makefile
@@ -20,7 +20,7 @@ USE_QT_VER= 3
MAKE_ENV+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
CONFIGURE_ENV= QTDIR=${X11BASE} LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
-HAS_CONFIGURE= yes
+MAKEFILE= BSDmakefile
MAN1= rospell.1
@@ -30,10 +30,13 @@ MAN1= rospell.1
IGNORE= doesn't compile properly on 4.x systems
.endif
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} dictfiles.h
+
do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE}
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} ${ALL_TARGET}
do-install:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} install
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} ${INSTALL_TARGET}
.include <bsd.port.post.mk>